[bug#78252,1/5] gnu: Add python-petl.
Commit Message
* gnu/packages/python-xyz.scm (python-petl): New variable.
Change-Id: I535b88025a150591269d194210a8f2c49aada974
---
gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)
@@ -5936,6 +5936,27 @@ (define-public python-parsley
language.")
(license license:expat)))
+(define-public python-petl
+ (package
+ (name "python-petl")
+ (version "1.7.16")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "petl" version))
+ (sha256
+ (base32 "0ll7xcc9yrvrz9p9im6m8p69cwrqwmqx91px43hlbnjrv1jflbww"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-setuptools python-setuptools-scm python-wheel
+ python-pytest))
+ (home-page "https://github.com/petl-developers/petl")
+ (synopsis
+ "A Python package for extracting, transforming and loading tables of data.")
+ (description
+ "This package provides a Python package for extracting, transforming and loading
+tables of data.")
+ (license license:expat)))
+
(define-public python-polib
(package
(name "python-polib")