diff mbox series

[bug#68932,v2,1/1] gnu: Add r-rpresto.

Message ID 255cc6c0f0d1895b0053c296483bd570aed1eaed.1708767269.git.sharlatanus@gmail.com
State New
Headers show
Series [bug#68932,v2,1/1] gnu: Add r-rpresto. | expand

Commit Message

Sharlatan Hellseher Feb. 24, 2024, 9:43 a.m. UTC
From: nafkhamdc <navid.afkhami@mdc-berlin.de>

* gnu/packages/cran.scm (r-rpresto): New variable.

Change-Id: I81b0e43ca75ab2df36f67367bfc73c4893be1a30
Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
---
 gnu/packages/cran.scm | 39 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index fb053074a1..23cf64ee36 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -37,6 +37,7 @@ 
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2022, 2023 Navid Afkhami <navid.afkhami@mdc-berlin.de>
 ;;; Copyright © 2022 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2024 nafkhamdc <navid.afkhami@mdc-berlin.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1495,6 +1496,44 @@  (define-public r-pma
 canonical correlation analysis.")
     (license license:gpl2+)))
 
+(define-public r-rpresto
+  (package
+    (name "r-rpresto")
+    (version "1.4.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "RPresto" version))
+       (sha256
+        (base32 "1q8c3h328iwscnayxj8qc71s2hkqdqwnpf38kn3zz3ks66qzjf8c"))))
+    (properties `((upstream-name . "RPresto")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-bit64
+           r-dbi
+           r-dbplyr
+           r-dplyr
+           r-httr
+           r-jsonlite
+           r-lifecycle
+           r-lubridate
+           r-openssl
+           r-progress
+           r-purrr
+           r-rlang
+           r-stringi
+           r-tibble
+           r-vctrs))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/prestodb/RPresto")
+    (synopsis "DBI connector to Presto")
+    (description
+     "This package implements a DBI compliant interface to
+@url{https://prestodb.io/, Presto} - a distributed SQL query engine for
+running interactive analytic queries against data sources of all sizes ranging
+from gigabytes to petabytes.")
+    (license license:bsd-3)))
+
 (define-public r-prettydoc
   (package
     (name "r-prettydoc")