diff mbox series

[bug#56729,RFC,v3,09/32] gnu: Add palp.

Message ID 25202f808c3f2b1fa6c89fe568b267ad1bd3042a.1685391447.git.guix@ikherbers.com
State New
Headers show
Series None | expand

Commit Message

vicvbcun May 29, 2023, 8:38 p.m. UTC
* gnu/packages/maths.scm (palp): New variable.
---

Notes:
    sage's build/pkgs/palp/SPKG.rst contains a description

 gnu/packages/maths.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index d92b8528a0..c2d9d07b00 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3158,6 +3158,37 @@  (define-public maxflow
 September 2004}")
     (license license:gpl3+)))
 
+(define-public palp
+  (package
+    (name "palp")
+    (version "2.20")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "http://hep.itp.tuwien.ac.at/~kreuzer/CY/palp/palp-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "1q1cl3vpdir16szy0jcadysydcrjp48hqxyx42kr8g9digkqjgkj"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list #:make-flags #~(list (string-append "CC=" #$(cc-for-target)))
+           #:tests? #f ; no tests
+           #:phases #~(modify-phases %standard-phases
+                        (delete 'configure)
+                        (replace 'install
+                          (lambda _
+                            (for-each
+                             (lambda (name)
+                               (install-file name (string-append #$output "/bin")))
+                             '("class.x" "cws.x" "mori.x" "nef.x" "poly.x")))))))
+    (home-page "http://hep.itp.tuwien.ac.at/~kreuzer/CY/CYpalp.html")
+    (synopsis "Package for Analyzing Lattice Polytopes")
+    (description
+     "PALP is a set of programs for calculations with lattice polytopes and
+applications to toric geometry.")
+    (license license:gpl3)))
+
 (define-public petsc
   (package
     (name "petsc")