diff mbox series

[bug#44215,4/4] gnu: kscreenlocker: Use qt-build-system.

Message ID 24b476c4814e1bd8271451010f11df3c3b08c505.1603659776.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Some smaller KDE changes. | expand

Checks

Context Check Description
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Hartmut Goebel Oct. 25, 2020, 9:09 p.m. UTC
* gnu/packages/kde-plasma.scm (kscreeenlocker)[buoild-system]: Change to
  qt-build-system. [arguments]{phases}<check> Remove unsued code; Actually
  disable running the tests.
---
 gnu/packages/kde-plasma.scm | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)

Comments

Efraim Flashner Oct. 27, 2020, 8:57 a.m. UTC | #1
How about gating the tests behind the tests? flag?

On Sun, Oct 25, 2020 at 10:09:22PM +0100, Hartmut Goebel wrote:
> * gnu/packages/kde-plasma.scm (kscreeenlocker)[buoild-system]: Change to
>   qt-build-system. [arguments]{phases}<check> Remove unsued code; Actually
>   disable running the tests.
> ---
>  gnu/packages/kde-plasma.scm | 7 +++----
>  1 file changed, 3 insertions(+), 4 deletions(-)
> 
> diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
> index ce6abb3a65..6e6213161c 100644
> --- a/gnu/packages/kde-plasma.scm
> +++ b/gnu/packages/kde-plasma.scm
> @@ -70,7 +70,7 @@ manager which re-parents a Client window to a window decoration frame.")
>                (sha256
>                 (base32
>                  "1lhq9rxafbbxwpwzq8m25xi9hgcdfdfwl8hafqhygzp14z89q9ml"))))
> -    (build-system cmake-build-system)
> +    (build-system qt-build-system)
>      (arguments
>       `(#:phases

        `(#:tests? #f
          #:phases

>         (modify-phases %standard-phases
> @@ -84,12 +84,11 @@ manager which re-parents a Client window to a window decoration frame.")
>           ;; Tests use the installed library and require a DBus session.
>           (add-after 'install 'check
>             (lambda _
> -             (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
> -             (invoke "dbus-launch" "ctest" "."))))))
> +             ;;(invoke "dbus-launch" "ctest" ".") ;; FIXME: try to make this pass
> +             #t)))))

(lambda* (#:key tests? #:allow-other-keys)
  (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
  (if tests?
    (invoke "dbus-launch" "ctest" ".")
    #t))


>      (native-inputs
>       `(("extra-cmake-modules" ,extra-cmake-modules)
>         ("pkg-config" ,pkg-config)
> -
>         ;; For tests.
>         ("dbus" ,dbus)
>         ("xorg-server" ,xorg-server-for-tests)))
> -- 
> 2.21.3
> 
> 
> 
>
Hartmut Goebel Oct. 27, 2020, 7:17 p.m. UTC | #2
Thanks for the quick response. I fixed the issues and pushed as
0f4c320c2c831aa1ce38fc908c86a8dc79316811
Efraim Flashner Oct. 28, 2020, 6:41 a.m. UTC | #3
On Tue, Oct 27, 2020 at 08:17:11PM +0100, Hartmut Goebel wrote:
> Thanks for the quick response. I fixed the issues and pushed as
> 0f4c320c2c831aa1ce38fc908c86a8dc79316811
> 

You actually have a one-armed if statement now. Invoke will return #t if
it works, else it returns undefined and the phase returns true. It still
works though :).
diff mbox series

Patch

diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index ce6abb3a65..6e6213161c 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -70,7 +70,7 @@  manager which re-parents a Client window to a window decoration frame.")
               (sha256
                (base32
                 "1lhq9rxafbbxwpwzq8m25xi9hgcdfdfwl8hafqhygzp14z89q9ml"))))
-    (build-system cmake-build-system)
+    (build-system qt-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
@@ -84,12 +84,11 @@  manager which re-parents a Client window to a window decoration frame.")
          ;; Tests use the installed library and require a DBus session.
          (add-after 'install 'check
            (lambda _
-             (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
-             (invoke "dbus-launch" "ctest" "."))))))
+             ;;(invoke "dbus-launch" "ctest" ".") ;; FIXME: try to make this pass
+             #t)))))
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
        ("pkg-config" ,pkg-config)
-
        ;; For tests.
        ("dbus" ,dbus)
        ("xorg-server" ,xorg-server-for-tests)))