diff mbox series

[bug#56729,RFC,v3,06/32] gnu: Add primecount.

Message ID 24a3bffb7b6f7e22c0adf2a3a218592deb48d904.1685391447.git.guix@ikherbers.com
State New
Headers show
Series None | expand

Commit Message

vicvbcun May 29, 2023, 8:38 p.m. UTC
* gnu/packages/algebra.scm (primecount): New variable.
---
 gnu/packages/algebra.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 3babf90b3c..68a0427f59 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -1901,3 +1901,27 @@  (define-public parform
     (description (string-append (package-description form)
                                 "  This package also includes
 @code{parform}, a version of FORM parallelized using OpenMPI."))))
+
+(define-public primecount
+  (package
+    (name "primecount")
+    (version "7.8")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/kimwalisch/primecount/")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0wsnavixdqi3ix3j4nqyi0hmhx309l1360nqrcxw5z60gg6kxaf8"))))
+    (build-system cmake-build-system)
+    (arguments
+     '(#:configure-flags (list "-DBUILD_SHARED_LIBS=ON" "-DBUILD_TESTS=ON")))
+    (home-page "https://github.com/kimwalisch/primecount/")
+    (synopsis "Fast prime counting function implementations")
+    (description
+     "@command{primecount} is a command-line program and C/C++ library that
+counts the number of primes ≤ x (maximum 10^31) using highly optimized
+implementations of the combinatorial prime counting algorithms.")
+    (license license:bsd-2)))