diff mbox series

[bug#67879,01/12] gnu: Add perl-www-pastebin-pastebincom-create.

Message ID 248f0c9ce5b6fcfad386ec7cfe32be533581a15b.1702918181.git.w@wmeyer.eu
State New
Headers show
Series Add perl-devel-repl. | expand

Commit Message

Wilko Meyer Dec. 18, 2023, 5:03 p.m. UTC
* gnu/packages/perl-web.scm (perl-www-pastebin-pastebincom-create): New variable.
* gnu/packages/perl-web.scm: Add my copyright header.

Change-Id: I2b8caa12f7230f00617a0e85e1fc8b95adc551c5
---
 gnu/packages/perl-web.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/perl-web.scm b/gnu/packages/perl-web.scm
index c3a3e17188..6e06bddfe4 100644
--- a/gnu/packages/perl-web.scm
+++ b/gnu/packages/perl-web.scm
@@ -2,6 +2,7 @@ 
 ;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2023 Wilko Meyer <w@wmeyer.eu>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -125,3 +126,28 @@  (define-public perl-uri-nested
      "@code{URI::Nested} provides support for nested URIs, where the scheme is
 a prefix, and the remainder of the URI is another URI.")
     (license license:perl-license)))
+
+(define-public perl-www-pastebin-pastebincom-create
+  (package
+    (name "perl-www-pastebin-pastebincom-create")
+    (version "1.003")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://cpan/authors/id/Z/ZO/ZOFFIX/WWW-Pastebin-PastebinCom-Create-"
+             version ".tar.gz"))
+       (sha256
+        (base32 "0xs29hilmlr51hcg4azbvi7c30yivan5gzwiq2z0dwrdy13lvcln"))))
+    (build-system perl-build-system)
+    ;; TODO: tests currently fail, disabled for now
+    (arguments
+      `(#:tests? #f))
+    (native-inputs (list perl-module-build))
+    (propagated-inputs (list perl-moo perl-www-mechanize))
+    (home-page "https://metacpan.org/release/WWW-Pastebin-PastebinCom-Create")
+    (synopsis "Paste on www.pastebin.com without API keys")
+    (description "@code{WWW::Pastebin::PastebinCom::Create} provides functionality
+to paste on pastebin.com without API keys.")
+    (license license:artistic2.0)))
+