diff mbox series

[bug#69212,RFC,3/4] gnu: Add perl-arxiv.

Message ID 24808bdbad7760f287615e15d5a1f698386185c3.1708211806.git.liliana.prikler@gmail.com
State New
Headers show
Series Add AutoTeX. | expand

Commit Message

Liliana Marie Prikler Feb. 17, 2024, 10:45 p.m. UTC
* gnu/packages/perl-tex.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Register it here.
---
 gnu/local.mk              |  1 +
 gnu/packages/perl-tex.scm | 44 +++++++++++++++++++++++++++++++++++++++
 2 files changed, 45 insertions(+)
 create mode 100644 gnu/packages/perl-tex.scm
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index becca7dd56..aec8e7eab6 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -510,6 +510,7 @@  GNU_SYSTEM_MODULES =				\
   %D%/packages/perl-check.scm			\
   %D%/packages/perl-compression.scm		\
   %D%/packages/perl-maths.scm			\
+  %D%/packages/perl-tex.scm			\
   %D%/packages/perl-web.scm			\
   %D%/packages/perl6.scm			\
   %D%/packages/photo.scm			\
diff --git a/gnu/packages/perl-tex.scm b/gnu/packages/perl-tex.scm
new file mode 100644
index 0000000000..315d34856f
--- /dev/null
+++ b/gnu/packages/perl-tex.scm
@@ -0,0 +1,44 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2024 Liliana Marie Prikler <liliana.prikler@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages perl-tex)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system perl)
+  #:use-module (gnu packages)
+  #:use-module (gnu packages perl)
+  #:use-module (gnu packages tex))
+
+(define-public perl-arxiv
+  (package
+    (name "perl-arxiv")
+    (version "1.01")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/S/SI/SIMEON/arXiv-" version
+                           ".tar.gz"))
+       (sha256
+        (base32 "0swcgkncc0vk220g5jwpz9j5zyg2995csklmfv09lhwxf6ndrin2"))))
+    (build-system perl-build-system)
+    (home-page "https://metacpan.org/release/arXiv")
+    (synopsis "Utilities from arXiv.org")
+    (description "This package contains perl modules with utility procedures
+used by other perl software at arXiv.org, most notably AutoTeX.")
+    (license license:perl-license)))