[bug#74860,v3,09/12] home: services: Add log rotation service.
Commit Message
* gnu/home/services/admin.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
* doc/guix.texi (Shepherd Home Service): Document it.
Change-Id: I37ac171147c236b05d6d3b226e9072ab7524dfe9
---
doc/guix.texi | 15 +++++++++++++++
gnu/home/services/admin.scm | 31 +++++++++++++++++++++++++++++++
gnu/local.mk | 1 +
3 files changed, 47 insertions(+)
create mode 100644 gnu/home/services/admin.scm
@@ -20909,6 +20909,7 @@ Log Rotation
be a @code{log-rotation-configuration} record, as discussed below.
@end defvar
+@anchor{log-rotation-configuration}
@c %start of fragment
@deftp {Data Type} log-rotation-configuration
@@ -47090,6 +47091,20 @@ Shepherd Home Service
@end table
@end deftp
+@cindex log rotation, for user services
+The Shepherd also comes with a @dfn{log rotation service}, which
+compresses and then deletes old log files produced by services and
+daemons that it runs. This service is made available through
+@code{home-log-rotation-service-type} as described below.
+
+@defvar home-log-rotation-service-type
+This is the service type for the user Shepherd log rotation service
+(@pxref{Log Rotation Service,,, shepherd, The GNU Shepherd Manual}).
+Its value must be a @code{log-rotation-configuration} record, exactly as
+for its system-wide counterpart. @xref{log-rotation-configuration}, for
+its reference.
+@end defvar
+
@node Secure Shell
@subsection Secure Shell
new file mode 100644
@@ -0,0 +1,31 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2024 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu home services admin)
+ #:use-module (gnu home services)
+ #:use-module (gnu services)
+ #:use-module (gnu services admin)
+ ;; For the 'home-shepherd-service-type' mapping.
+ #:use-module (gnu home services shepherd)
+ #:export (home-log-rotation-service-type)
+ #:re-export (log-rotation-configuration))
+
+(define home-log-rotation-service-type
+ (service-type
+ (inherit (system->home-service-type log-rotation-service-type))
+ (default-value (for-home (log-rotation-configuration)))))
@@ -100,6 +100,7 @@ GNU_SYSTEM_MODULES = \
%D%/compression.scm \
%D%/home.scm \
%D%/home/services.scm \
+ %D%/home/services/admin.scm \
%D%/home/services/desktop.scm \
%D%/home/services/dict.scm \
%D%/home/services/dotfiles.scm \