diff mbox series

[bug#38631] gnu: Add python-sphinx-intl

Message ID 24107d9f065bebf5cee1704e28d39e5152843686.camel@zrythm.org
State Accepted
Headers show
Series [bug#38631] gnu: Add python-sphinx-intl | expand

Commit Message

Alexandros Theodotou Dec. 16, 2019, 4:42 a.m. UTC

Comments

Brett Gilio Dec. 16, 2019, 4:56 a.m. UTC | #1
Thanks, pushed with 90ee17cdac77e48603b93ab30b71c4ba7ce2db42.
diff mbox series

Patch

From 4b2f0f172bf69f24c92273a2307a05ad18bf0bcb Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Mon, 16 Dec 2019 04:39:44 +0000
Subject: [PATCH] gnu: Add python-sphinx-intl

* gnu/packages/sphinx.scm (python-sphinx-intl): New variable.
---
 gnu/packages/sphinx.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index b74137362c..d424d94414 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -11,6 +11,7 @@ 
 ;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
 ;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -565,3 +566,26 @@  and several other projects.")
     (description "This package is an extension to reStructuredText and Sphinx
 to be able to read and render the Doxygen xml output.")
     (license license:bsd-3)))
+
+(define-public python-sphinx-intl
+  (package
+    (name "python-sphinx-intl")
+    (version "2.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "sphinx-intl" version))
+       (sha256
+        (base32
+         "0zbf1bh23b3kza8bnjykmv2k21xmmr4gamhi3lnicnr6ypnrphr5"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-sphinx" ,python-sphinx)
+       ("python-click" ,python-click)))
+    (home-page "https://github.com/sphinx-doc/sphinx-intl")
+    (synopsis
+      "Sphinx utility that makes it easy to translate and to apply translation")
+    (description
+      "sphinx-intl is a utility tool that provides several features that make
+it easy to translate and to apply translation to Sphinx generated document.")
+    (license license:bsd-2)))
-- 
2.24.1