diff mbox series

[bug#40270,2/2] gnu: Add python-flask-session.

Message ID 23d1eb780cb76093bba9da0d5bcd92a5@airmail.cc
State Accepted
Headers show
Series [bug#40270,1/2] gnu: Add python-flask-markdown. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

pinoaffe March 28, 2020, 9:36 a.m. UTC
* gnu/packages/python-web.scm (python-flask-session, 
python2-flask-session): New variables.
---
  gnu/packages/python-web.scm | 27 +++++++++++++++++++++++++++
  1 file changed, 27 insertions(+)

      (name "python-html5lib")

Comments

Marius Bakke March 29, 2020, 8:11 p.m. UTC | #1
pinoaffe@airmail.cc writes:

> * gnu/packages/python-web.scm (python-flask-session, 
> python2-flask-session): New variables.

I have the same comments on this package as the python-flask-markdown
patch.  Can you send an updated patch?

Also the python2 variants can be omitted unless you plan on using them.
Python 2 is deprecated, so we do not add new Python 2 packages unless
required by something else.
Christopher Baines Nov. 21, 2020, 9:15 a.m. UTC | #2
Marius Bakke <mbakke@fastmail.com> writes:

> pinoaffe@airmail.cc writes:
>
>> * gnu/packages/python-web.scm (python-flask-session,
>> python2-flask-session): New variables.
>
> I have the same comments on this package as the python-flask-markdown
> patch.  Can you send an updated patch?
>
> Also the python2 variants can be omitted unless you plan on using them.
> Python 2 is deprecated, so we do not add new Python 2 packages unless
> required by something else.

It's been a few months, are these patches still relevant?

Thanks,

Chris
pinoaffe Nov. 22, 2020, 5:49 p.m. UTC | #3
thanks for the reminder,
I'd completely forgotten about these patches,
will send new ones with the changes you suggested applied in a minute

On 2020-11-21 09:15, Christopher Baines wrote:
> Marius Bakke <mbakke@fastmail.com> writes:
> 
>> pinoaffe@airmail.cc writes:
>> 
>>> * gnu/packages/python-web.scm (python-flask-session,
>>> python2-flask-session): New variables.
>> 
>> I have the same comments on this package as the python-flask-markdown
>> patch.  Can you send an updated patch?
>> 
>> Also the python2 variants can be omitted unless you plan on using 
>> them.
>> Python 2 is deprecated, so we do not add new Python 2 packages unless
>> required by something else.
> 
> It's been a few months, are these patches still relevant?
> 
> Thanks,
> 
> Chris
Christopher Baines Nov. 28, 2020, 12:33 p.m. UTC | #4
pinoaffe@airmail.cc writes:

> thanks for the reminder,
> I'd completely forgotten about these patches,
> will send new ones with the changes you suggested applied in a minute

Awesome, thanks, I'll have a look at the new patches momentarily.
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index db66f1ed4d..acca981eee 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -500,6 +500,33 @@  both of which are installed automatically if you 
install this library.")
  (define-public python2-flask-markdown
    (package-with-python2 python-flask-markdown))

+(define-public python-flask-session
+  (package
+    (name "python-flask-session")
+    (version "0.3.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "Flask-Session" version))
+        (sha256
+          (base32
+            "0cd7h5c236m6smyixnyfrks4spsqp9d65ndk4p400zr8qgh2f753"))))
+    (build-system python-build-system)
+    (arguments
+       `(#:tests? #f))
+    (propagated-inputs
+      `(("python-flask" ,python-flask)))
+    (home-page
+      "https://github.com/fengsp/flask-session")
+    (synopsis
+      "Adds server-side session support to your Flask application")
+    (description
+      "Adds server-side session support to your Flask application")
+    (license license:bsd-3)))
+
+(define-public python2-flask-session
+  (package-with-python2 python-flask-session))
+
  (define-public python-html5lib
    (package