diff mbox series

[bug#69955,gnome-team] gnu: shotwell: Update to 0.32.6.

Message ID 23c28e36618ec13a08e02922939e626252f81e0e.1711182652.git.vivien@planete-kraus.eu
State New
Headers show
Series [bug#69955,gnome-team] gnu: shotwell: Update to 0.32.6. | expand

Commit Message

Vivien Kraus March 23, 2024, 8:29 a.m. UTC
* gnu/packages/gnome.scm (shotwell): Update to 0.32.6.
[arguments]: Convert to list of G-Expressions.
[#:phase 'skip-gtk-update-icon-cache]: Adjust to build system change.
[inputs]: Add libportal.

Change-Id: I5167d13d8514e278732459d1705f0041e3797894
---
Dear Guix,

This shotwell update fixes its build failure on gnome-team.

What do you think?

Best regards,

Vivien

 gnu/packages/gnome.scm | 24 ++++++++++++++----------
 1 file changed, 14 insertions(+), 10 deletions(-)


base-commit: a9951a74a591a9b22ee2d93d8efe0523c6c42c97

Comments

Christopher Baines March 24, 2024, 10:32 a.m. UTC | #1
Vivien Kraus via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/gnome.scm (shotwell): Update to 0.32.6.
> [arguments]: Convert to list of G-Expressions.
> [#:phase 'skip-gtk-update-icon-cache]: Adjust to build system change.
> [inputs]: Add libportal.
>
> Change-Id: I5167d13d8514e278732459d1705f0041e3797894
> ---
> Dear Guix,
>
> This shotwell update fixes its build failure on gnome-team.
>
> What do you think?

Looks good to me, I've pushed this to gnome-team as
beec25533869437b95735965ac130ea5f59f5aa0.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 5432ebc27b..06ab604945 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7570,7 +7570,7 @@  (define-public gexiv2
 (define-public shotwell
   (package
     (name "shotwell")
-    (version "0.31.5")
+    (version "0.32.6")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/shotwell/"
@@ -7578,17 +7578,20 @@  (define-public shotwell
                                   "shotwell-" version ".tar.xz"))
               (sha256
                (base32
-                "06awlix23y1cd89n6v9vip48cg08fjq8v6zaw38k5clrrv38y11v"))))
+                "1dkh5bczf9k86akl70inpc2z98qkhg8g44jb2kc8rqcimkzs95vm"))))
     (build-system meson-build-system)
     (arguments
-     '(#:glib-or-gtk? #t
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'skip-gtk-update-icon-cache
-           (lambda _
-             (substitute* "build-aux/meson/postinstall.py"
-               (("gtk-update-icon-cache") (which "true"))
-               (("update-desktop-database") (which "true"))))))))
+     (list
+      #:glib-or-gtk? #t
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'skip-gtk-update-icon-cache
+            (lambda _
+              (substitute* "meson.build"
+                (("gtk_update_icon_cache: true")
+                 "gtk_update_icon_cache: false")
+                (("update_desktop_database: true")
+                 "update_desktop_database: false")))))))
     (propagated-inputs
      (list dconf))
     (native-inputs
@@ -7604,6 +7607,7 @@  (define-public shotwell
            gst-plugins-base
            gstreamer
            json-glib
+           libportal
            libgdata
            libgee
            libgphoto2