diff mbox series

[bug#60825,1/2] gnu: libavif: Update to 0.11.1.

Message ID 23872b75712660593afaa19c0498c7782e0a2b79.1673747078.git.mirai@makinata.eu
State New
Headers show
Series [bug#60825,1/2] gnu: libavif: Update to 0.11.1. | expand

Commit Message

Bruno Victal Jan. 15, 2023, 1:45 a.m. UTC
libavif commit 97306bf64266cf9571dd141f3d04492534a9deea removes
JSON-based tests along with cJSON.

Aditionally, googletest is now required to build libavif. The test target
has since changed and can be called directly from cmake, no longer being
necessary to replace 'check target.

* gnu/packages/image.scm (libavif): Update to 0.11.1.
[arguments]: Adjust configure-flags, remove 'check phase replacement.
[native-inputs]: Add googletest.
[license]: Remove expat.
---
 gnu/packages/image.scm | 15 ++++++---------
 1 file changed, 6 insertions(+), 9 deletions(-)


base-commit: c94708a5b4820c9253ef5774a1022fc106e7ae9a
diff mbox series

Patch

diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 195d127b31..0618c13460 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -2157,7 +2157,7 @@  (define-public icoutils
 (define-public libavif
   (package
     (name "libavif")
-    (version "0.9.2")
+    (version "0.11.1")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -2166,7 +2166,7 @@  (define-public libavif
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1yxmgjlxm1srm98zyj79bj8r8vmg67daqnq0ggcvxknq54plkznk"))))
+                "02zmb62g0yx6rfz4w1isyzfrckv5i7dzyz26rp2mspbx9w6v8j4r"))))
     (build-system cmake-build-system)
     (arguments
      (list
@@ -2175,13 +2175,10 @@  (define-public libavif
               #$@(if (this-package-input "rav1e")
                    '("-DAVIF_CODEC_RAV1E=ON")
                    '())
-              "-DAVIF_BUILD_TESTS=ON" "-DAVIF_BUILD_APPS=ON")
+              "-DAVIF_BUILD_TESTS=ON" "-DAVIF_ENABLE_GTEST=ON"
+              "-DAVIF_BUILD_APPS=ON")
       #:phases
       #~(modify-phases %standard-phases
-          (replace 'check
-            (lambda* (#:key tests? #:allow-other-keys)
-              (when tests?
-                (invoke "./aviftest" "../source/tests/data"))))
           (add-after 'install 'install-readme
             (lambda _
               (let ((doc (string-append #$output "/share/doc/libavif-" #$version)))
@@ -2200,6 +2197,7 @@  (define-public libavif
                             (chmod new #o555))
                           (list avifenc avifdec)
                           (list avifenc* avifdec*))))))))
+    (native-inputs (list googletest))
     (inputs
      (append
       (if (member (%current-system) (package-transitive-supported-systems rav1e))
@@ -2212,8 +2210,7 @@  (define-public libavif
 File Format}.  It can encode and decode all YUV formats and bit depths supported
 by AOM, including with alpha.")
     (home-page "https://github.com/AOMediaCodec/libavif")
-    (license (list license:bsd-2    ; libavif itself
-                   license:expat)))) ; cJSON in the test suite
+    (license (list license:bsd-2))))
 
 (define-public libheif
   (package