diff mbox series

[bug#68569,1/2] gnu: Add python-apprise.

Message ID 236d62db2eb224c0ae8ee7ea0fabecbb4dc4c929.1705586561.git.michaeldelago98@gmail.com
State New
Headers show
Series gnu: borgmatic: Update to 1.8.6 | expand

Commit Message

Mike Delago Jan. 18, 2024, 2:32 p.m. UTC
* gnu/packages/python-xyz.scm (python-apprise): New variable.

Change-Id: I24659780121e3d428002f504a459bea442790a7b
---
 gnu/packages/python-xyz.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

Comments

Maxim Cournoyer Jan. 21, 2024, 4:57 a.m. UTC | #1
Hi!

Mike Delago <michaeldelago98@gmail.com> writes:

> * gnu/packages/python-xyz.scm (python-apprise): New variable.
>
> Change-Id: I24659780121e3d428002f504a459bea442790a7b
> ---
>  gnu/packages/python-xyz.scm | 36 ++++++++++++++++++++++++++++++++++++
>  1 file changed, 36 insertions(+)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index aebbae1521..aecebb1dde 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -14364,6 +14364,42 @@ (define-public python-appdirs
>  should be stored on various operating systems.")
>      (license license:expat)))
>  
> +(define-public python-apprise
> +  (package
> +    (name "python-apprise")
> +    (version "1.7.1")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (pypi-uri "apprise" version))
> +       (sha256
> +        (base32 "0nkfv0pyn13lqdr3g3r1dhhnqxkjiayf9pny4m254w04al49shwd"))
> +       ;; MacOS tests are failing when attempting to mock terminal-notifier calls
> +       ;; We don't need to test for MacOS support, and removing this file causes
> +       ;; tests to succeed

Please punctuate your comments (including periods).

> +       (modules '((guix build utils)))
> +       (snippet '(begin
> +                   (delete-file-recursively "test/test_plugin_macosx.py")))))
> +    (build-system pyproject-build-system)
> +    (propagated-inputs (list python-certifi
> +                             python-click
> +                             python-markdown
> +                             python-pyyaml
> +                             python-requests
> +                             python-requests-oauthlib))
> +    (native-inputs (list python-babel
> +                         python-coverage
> +                         python-flake8
> +                         python-pytest
> +                         python-pytest-cov
> +                         python-pytest-mock
> +                         python-pytest-xdist))

Nitpick: I prefer to list inputs in the order of native, inputs,
propagated.  Was the above order produced by the pypi importer?

> +    (home-page "https://github.com/caronc/apprise")
> +    (synopsis "Push Notifications that work with just about every platform!")

This is too verbose for a synopsis.  Synopses should describe in a few
words what the package *is*, such as "Push notification library and
utility" (no trailing period here).

> +    (description
> +     "Push Notifications that work with just about every platform!")

That sounds like marketing talk.  Keep it dry and factual, synthesizing
the interesting technical bits from their description text available
from <https://github.com/caronc/apprise>.

> +    (license license:bsd-3)))

Github says bsd-2.  Could you check?

Other than that, it looks good to me.  Could you please send a v2 with the
requested changes?
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index aebbae1521..aecebb1dde 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14364,6 +14364,42 @@  (define-public python-appdirs
 should be stored on various operating systems.")
     (license license:expat)))
 
+(define-public python-apprise
+  (package
+    (name "python-apprise")
+    (version "1.7.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "apprise" version))
+       (sha256
+        (base32 "0nkfv0pyn13lqdr3g3r1dhhnqxkjiayf9pny4m254w04al49shwd"))
+       ;; MacOS tests are failing when attempting to mock terminal-notifier calls
+       ;; We don't need to test for MacOS support, and removing this file causes
+       ;; tests to succeed
+       (modules '((guix build utils)))
+       (snippet '(begin
+                   (delete-file-recursively "test/test_plugin_macosx.py")))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-certifi
+                             python-click
+                             python-markdown
+                             python-pyyaml
+                             python-requests
+                             python-requests-oauthlib))
+    (native-inputs (list python-babel
+                         python-coverage
+                         python-flake8
+                         python-pytest
+                         python-pytest-cov
+                         python-pytest-mock
+                         python-pytest-xdist))
+    (home-page "https://github.com/caronc/apprise")
+    (synopsis "Push Notifications that work with just about every platform!")
+    (description
+     "Push Notifications that work with just about every platform!")
+    (license license:bsd-3)))
+
 (define-public python-google-pasta
   (package
     (name "python-google-pasta")