[bug#69424,v2,2/5] gnu: font-google-noto: Prefer variable fonts and split outputs.
Commit Message
* gnu/packages/fonts.scm (font-google-noto)
[arguments]<#:phase>: Only install variable fonts to "out" when available.
Install hinted TTFs into "ttf" output.
[outputs]: Add "ttf".
Suggested-by: Jiwei YANG <yangjiwei@protonmail.com>
Change-Id: Icac2927fb6c35d08504c379e273a5fc03b08ac46
---
gnu/packages/fonts.scm | 44 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)
@@ -1092,6 +1092,50 @@ (define-public font-google-noto
(sha256
(base32 "087jg8ahpq35xwyrmvm9ivxl0wjic2j4r28bbrwqmgdva9brms40"))))
(build-system font-build-system)
+ (arguments
+ (list
+ #:modules
+ '((guix build font-build-system)
+ (guix build utils)
+ (ice-9 ftw))
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'install
+ (lambda _
+ (define install
+ (assoc-ref %standard-phases 'install))
+ (define (scan-directory name)
+ (scandir name (lambda (file)
+ (not (member file '("." ".." "LICENSE"))))))
+ (define (install-font-variant variant)
+ "Given font variant VARIANT, install one of its formats,
+variable TTF or OTF or TTF."
+ (with-directory-excursion variant
+ (let ((formats (scan-directory ".")))
+ (cond
+ ((member "variable-ttf" formats)
+ (with-directory-excursion "variable-ttf"
+ (install #:outputs `(("out" . ,#$output)))))
+ ((member "otf" formats)
+ (with-directory-excursion "otf"
+ (install #:outputs `(("out" . ,#$output)))))
+ ((member "ttf" formats)
+ (with-directory-excursion "ttf"
+ (install #:outputs `(("out" . ,#$output)))))))))
+ (define (install-font font)
+ "Given font FONT, install one of its variants, full or unhinted,
+and install its hinted variant into 'ttf' output.
+
+unhinted and hinted variants are always available."
+ (with-directory-excursion font
+ (if (member "full" (scan-directory "."))
+ (install-font-variant "full")
+ (install-font-variant "unhinted"))
+ (with-directory-excursion "hinted"
+ (install #:outputs `(("out" . ,#$output:ttf))))))
+ (with-directory-excursion "fonts"
+ (for-each install-font (scan-directory "."))))))))
+ (outputs '("out" "ttf"))
(home-page "https://www.google.com/get/noto/")
(synopsis "Fonts to cover all languages")
(description "Google Noto Fonts is a family of fonts designed to support