diff mbox series

[bug#63903,v2,07/11] gnu: Add go-github-com-technoweenie-multipartstreamer.

Message ID 23456827e2211f1f0b1dd09a8eaa490257729397.1685973062.git.hako@ultrarare.space
State New
Headers show
Series gnu: Add miniflux. | expand

Commit Message

Hilton Chain June 5, 2023, 1:52 p.m. UTC
* gnu/packages/golang.scm (go-github-com-technoweenie-multipartstreamer): New variable.
---
 gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c69a991290..4708d4395f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4323,6 +4323,30 @@  (define go-github-com-stretchr-testify-bootstrap
     (propagated-inputs
      (list go-gopkg-in-yaml-v3))))
 
+(define-public go-github-com-technoweenie-multipartstreamer
+  (package
+    (name "go-github-com-technoweenie-multipartstreamer")
+    (version "1.0.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/technoweenie/multipartstreamer")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "159jhcabdkds8m5777zfs8p5z3snpjhzz7q9aq9wjpcvh6xlljqa"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:tests? #f                  ; Upstream tests are broken.
+           #:import-path "github.com/technoweenie/multipartstreamer"))
+    (home-page "https://github.com/technoweenie/multipartstreamer")
+    (synopsis "MIME multipart format streamer")
+    (description
+     "This package helps you encode large files in MIME multipart format
+without reading the entire content into memory.")
+    (license license:expat)))
+
 (define-public go-github-com-tevino-abool
   (let ((commit
           "3c25f2fe7cd0ef3eabefce1d90efd69a65d35b12")