[bug#77758] gnu: mc: Update to 4.8.33.
Commit Message
* gnu/packages/mc.scm (mc): Update to 4.8.33.
[arguments](phases): Remove uid/gid patch in 'fix-tests.
[inputs]: Add python.
Change-Id: Ie709ec8d4b4c3c278367933bdd1777d0535523f1
---
gnu/packages/mc.scm | 13 ++++---------
1 file changed, 4 insertions(+), 9 deletions(-)
base-commit: 63f323fc98fb6e85c48721574aab8e54d95091e5
Comments
@@ -28,6 +28,7 @@ (define-module (gnu packages mc)
#:use-module (gnu packages linux)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages perl)
+ #:use-module (gnu packages python)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages ssh)
#:use-module (gnu packages)
@@ -40,14 +41,14 @@ (define-module (gnu packages mc)
(define-public mc
(package
(name "mc")
- (version "4.8.32")
+ (version "4.8.33")
(source
(origin
(method url-fetch)
(uri (string-append "https://ftp.osuosl.org/pub/midnightcommander/mc-"
version ".tar.xz"))
(sha256
- (base32 "1zjr2d6r8w0f78nww42168cndkw79gsqgfgandij7bz9xp8q7p2d"))))
+ (base32 "0k0nmxlb95nqm40251azqqaa53rsj6rps7f8v22m2kl45za4kqfa"))))
(build-system gnu-build-system)
(arguments
(list
@@ -88,13 +89,6 @@ (define-public mc
(which "sh")))))
(add-before 'check 'fix-tests
(lambda _
- ;; Don't expect a UID or GID of ‘0’ in the build environment.
- (with-directory-excursion "tests/src/vfs/extfs/helpers-list/data"
- (substitute* (list "rpm.custom.output"
- "rpm.glib.output")
- ((" 0 0") "<<uid>> <<gid>>")))
- ;; XXX ERROR:mc_realpath.c:99:realpath_test: assertion failed
- ;; (resolved_path == data->expected_string): ("" == "/usr/bin")
(substitute* "tests/lib/mc_realpath.c"
(("/usr/bin") "/")
(("usr/bin") "/")))))))
@@ -107,6 +101,7 @@ (define-public mc
libssh2
ncurses
perl
+ python
unzip))
(home-page "https://www.midnight-commander.org")
(properties