[bug#77758] gnu: mc: Update to 4.8.33.

Message ID 2334e9be90fecad7a6bb006100085bbf2a0c1df6.1744446069.git.atai@atai.org
State New
Headers
Series [bug#77758] gnu: mc: Update to 4.8.33. |

Commit Message

Andy Tai April 12, 2025, 8:23 a.m. UTC
  * gnu/packages/mc.scm (mc): Update to 4.8.33.
[arguments](phases): Remove uid/gid patch in 'fix-tests.
[inputs]: Add python.

Change-Id: Ie709ec8d4b4c3c278367933bdd1777d0535523f1
---
 gnu/packages/mc.scm | 13 ++++---------
 1 file changed, 4 insertions(+), 9 deletions(-)


base-commit: 63f323fc98fb6e85c48721574aab8e54d95091e5
  

Comments

Andreas Enge April 14, 2025, 8:17 a.m. UTC | #1
Pushed, thanks!

Andreas
  

Patch

diff --git a/gnu/packages/mc.scm b/gnu/packages/mc.scm
index 07925328b5d..74376dbbf60 100644
--- a/gnu/packages/mc.scm
+++ b/gnu/packages/mc.scm
@@ -28,6 +28,7 @@  (define-module (gnu packages mc)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages perl)
+  #:use-module (gnu packages python)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages ssh)
   #:use-module (gnu packages)
@@ -40,14 +41,14 @@  (define-module (gnu packages mc)
 (define-public mc
   (package
     (name "mc")
-    (version "4.8.32")
+    (version "4.8.33")
     (source
      (origin
       (method url-fetch)
       (uri (string-append "https://ftp.osuosl.org/pub/midnightcommander/mc-"
                           version ".tar.xz"))
       (sha256
-       (base32 "1zjr2d6r8w0f78nww42168cndkw79gsqgfgandij7bz9xp8q7p2d"))))
+       (base32 "0k0nmxlb95nqm40251azqqaa53rsj6rps7f8v22m2kl45za4kqfa"))))
     (build-system gnu-build-system)
     (arguments
      (list
@@ -88,13 +89,6 @@  (define-public mc
                  (which "sh")))))
           (add-before 'check 'fix-tests
             (lambda _
-              ;; Don't expect a UID or GID of ‘0’ in the build environment.
-              (with-directory-excursion "tests/src/vfs/extfs/helpers-list/data"
-                (substitute* (list "rpm.custom.output"
-                                   "rpm.glib.output")
-                  (("      0        0") "<<uid>>  <<gid>>")))
-              ;; XXX ERROR:mc_realpath.c:99:realpath_test: assertion failed
-              ;; (resolved_path == data->expected_string): ("" == "/usr/bin")
               (substitute* "tests/lib/mc_realpath.c"
                 (("/usr/bin") "/")
                 (("usr/bin") "/")))))))
@@ -107,6 +101,7 @@  (define-public mc
                   libssh2
                   ncurses
                   perl
+                  python
                   unzip))
     (home-page "https://www.midnight-commander.org")
     (properties