diff mbox series

[bug#68908] gnu: Add ocaml-dune-private-libs.

Message ID 22782da727d7d93f129d6247ab19e5bd84b2976c.1706972151.git.soeren@soeren-tempel.net
State New
Headers show
Series [bug#68908] gnu: Add ocaml-dune-private-libs. | expand

Commit Message

Sören Tempel Feb. 3, 2024, 3:12 p.m. UTC
From: Sören Tempel <soeren@soeren-tempel.net>

* gnu/packages/ocaml.scm (ocaml-dune-private-libs): New variable.

Signed-off-by: Sören Tempel <soeren@soeren-tempel.net>
---
 gnu/packages/ocaml.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 4d61610335..f2d18d0205 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -8350,6 +8350,25 @@  (define-public ocaml-stdune
 provide any backwards compatibility or stability guarantees.")
     (license license:expat)))
 
+(define-public ocaml-dune-private-libs
+  (package
+    (inherit dune)
+    (name "ocaml-dune-private-libs")
+    (build-system dune-build-system)
+    (arguments
+     '(#:package "dune-private-libs"
+       ;; No separate test suite from dune.
+       #:tests? #f))
+    (propagated-inputs (list ocaml-csexp ocaml-pp ocaml-dyn ocaml-stdune
+                             ocaml-odoc))
+    (synopsis "Private libraries of Dune")
+    (description
+     "This OCaml library provides several private APIs shared between
+various Dune-internal packages.  It is not intended for public use by
+the authors and does therefore not provide any stability guarantees.
+Nonetheless, many OCaml packages depend on this library.")
+    (license license:expat)))
+
 (define-public ocaml-dune-build-info
   (package
     (inherit dune)