[bug#77050] gnu: lynx: Set native-search-paths.
Commit Message
This allows discovery of certificates upon adding nss-certs into the profile.
* gnu/packages/web-browsers.scm (lynx)[native-search-paths]: Set to
$SSL_CERT_DIR and $SSL_CERT_FILE.
[arguments]: Fix indentation.
Change-Id: Ib2383bd21a4177f87067a12aeb987b2591f3f4e8
---
gnu/packages/web-browsers.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)
@@ -109,7 +109,8 @@ (define-module (gnu packages web-browsers)
#:use-module (gnu packages web)
#:use-module (gnu packages webkit)
#:use-module (gnu packages xml)
- #:use-module (gnu packages xorg))
+ #:use-module (gnu packages xorg)
+ #:use-module ((guix search-paths) #:select ($SSL_CERT_DIR $SSL_CERT_FILE)))
(define-public midori
(package
@@ -375,6 +376,7 @@ (define-public lynx
zlib
gzip
bzip2))
+ (native-search-paths (list $SSL_CERT_DIR $SSL_CERT_FILE))
(arguments
(list #:configure-flags
#~(let ((openssl #$(this-package-input "openssl")))
@@ -396,7 +398,7 @@ (define-public lynx
#~(modify-phases %standard-phases
(add-before 'configure 'set-makefile-shell
(lambda _ (substitute* "po/makefile.inn"
- (("/bin/sh") (which "sh")))))
+ (("/bin/sh") (which "sh")))))
(replace 'install
(lambda* (#:key (make-flags '()) #:allow-other-keys)
(apply invoke "make" "install-full" make-flags))))))