diff mbox series

[bug#64934,11/42] gnu: Add java-httpcomponents-httpcore-osgi.

Message ID 221d20b80ecc4fb28f27229660cd11ec2ac9a2b3.1690646441.git.liliana.prikler@gmail.com
State New
Headers show
Series I tried to semantic the web, and after downloading half the Internet, these are some packages I came up with | expand

Commit Message

Liliana Marie Prikler July 29, 2023, 2:50 p.m. UTC
* gnu/packages/java.scm (java-httpcomponents-httpcore-osgi): New variable.
---
 gnu/packages/java.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 18d56a18c5..c84d34634a 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -6242,6 +6242,32 @@  (define-public java-httpcomponents-httpcore-ab
     (description "This package provides the HttpCore benchmarking tool.  It is
 an Apache AB clone based on HttpCore.")))
 
+(define-public java-httpcomponents-httpcore-osgi
+  (package (inherit java-httpcomponents-httpcore)
+    (name "java-httpcomponents-httpcore-osgi")
+    (arguments
+     `(#:jar-name "httpcomponents-httpcore-osgi.jar"
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'chdir
+           (lambda _ (chdir "httpcore-osgi"))))))
+    (inputs
+     (modify-inputs (package-inputs java-httpcomponents-httpcore)
+                    (prepend java-httpcomponents-httpcore
+                             java-httpcomponents-httpcore-nio
+                             java-hamcrest-core)))
+    (native-inputs (list java-ops4j-pax-exam-core
+                         java-ops4j-pax-exam-core-junit
+                         java-ops4j-pax-exam-core-spi
+                         java-junit))
+    (description "HttpCore is a set of low level HTTP transport components
+that can be used to build custom client and server side HTTP services with a
+minimal footprint.  HttpCore supports two I/O models: blocking I/O model based
+on the classic Java I/O and non-blocking, event driven I/O model based on Java
+NIO.
+
+This package provides... some tests.")))
+
 (define-public java-httpcomponents-httpclient
   (package
     (name "java-httpcomponents-httpclient")