diff mbox series

[bug#71084,24/26] gnu: Add python-comm.

Message ID 221b70d271a0f03aa36edb10a6d2ecb87b6ad31d.1716242564.git.sharlatanus@gmail.com
State New
Headers show
Series Astronomy update 2024/05. | expand

Commit Message

Sharlatan Hellseher May 20, 2024, 10:12 p.m. UTC
* gnu/packages/jupyter.scm (python-comm): New variable.

Change-Id: I1bed7b6f54e63db6f47cdbaccd816c56f06045f8
---
 gnu/packages/jupyter.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index ef68521b53..7ff6202665 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -4,6 +4,7 @@ 
 ;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
 ;;; Copyright © 2022 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -491,6 +492,32 @@  (define-public python-jupyter-server-mathjax
 Mathjax, the JavaScript display engine for mathematics.")
     (license license:bsd-3)))
 
+(define-public python-comm
+  (package
+    (name "python-comm")
+    (version "0.2.2")
+    (source
+     (origin
+       (method git-fetch)   ; no tests data in PyPi package
+       (uri (git-reference
+             (url "https://github.com/ipython/comm")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "18xsbpd8dgcfbc51xl59nlwaq7jnyzvgzjfj6psscv71894x4lg7"))))
+    (build-system pyproject-build-system)
+    (native-inputs
+     (list python-hatchling python-pytest python-setuptools-scm))
+    (propagated-inputs
+     (list python-traitlets))
+    (home-page "https://github.com/ipython/comm")
+    (synopsis "Python Comm implementation for the Jupyter kernel protocol")
+    (description
+     "This package provides a way to register a Kernel Comm implementation, as
+per the Jupyter kernel protocol. It also provides a base Comm implementation
+and a default CommManager that can be used.")
+    (license license:bsd-3)))
+
 (define-public python-nbclient
   (package
     (name "python-nbclient")