diff mbox series

[bug#47874] gnu: Add kirc.

Message ID 2200031618741698@mail.yandex.com
State Accepted
Headers show
Series [bug#47874] gnu: Add kirc. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

WinterHound April 18, 2021, 10:35 a.m. UTC

Comments

Leo Famulari April 18, 2021, 6:58 p.m. UTC | #1
On Sun, Apr 18, 2021 at 04:05:11PM +0530, Winter Hound wrote:
> From f77caa31810add7bddc321f3980170e494f648d4 Mon Sep 17 00:00:00 2001
> From: WinterHound <winterhound@yandex.com>
> Date: Sun, 18 Apr 2021 15:55:23 +0530
> Subject: [PATCH] gnu: Add kirc.

Thanks for the patch!

I pushed it as 3ddece896fddc38a29ab7e69f7c74f35e5a381fb with the
following changes:


> +              (method url-fetch)
> +              (uri (string-append "https://github.com/mcpcpc/kirc/archive/refs/tags/" version
> +                                  ".tar.gz"))

I changed the source to fetch from Git. This type of tarball, which is
named "Source code (tar.gz)" on the web site, is generated automatically
by GitHub. These auto-generated tarballs actually change over time, as
GitHub updates their software. So, we fetch from Git in this case, to
ensure that package source will always be bit-identical.

> +    (synopsis "A tiny IRC client written in POSIX C99")

`guix lint kirc` complained that the synopsis starts with an "article",
that is, with "A [...]". So I removed it.

> +    (description
> +     "A tiny open-source Internet Relay Chat (IRC) client designed with usability and cross-platform compatibility in mind.
> +Features
> +    No dependencies other than a C99 compiler.
> +    Simple Authentication and Security Layer (SASL) procotol support.
> +    Client-to-client (CTCP) protocol support.
> +    Transport Layer Security (TLS) protocol support (via external utilities).
> +    Simple chat history logging.
> +    Asynchronous message handling.
> +    Multi-channel joining at server connection.
> +    Full support for all RFC 2812 commands.
> +    Easy customized color scheme definition.")

And I removed what I consider "marketing language" from the synopsis and
description, and suggested in our manual's Synopses and Descriptions
section:

https://guix.gnu.org/manual/en/html_node/Synopses-and-Descriptions.html#Synopses-and-Descriptions

For example, the word "tiny" is subjective, and I think all programs
designed to be "usable" :)

Finally, I made sure to import the module (guix utils) in (gnu packages
irc). Otherwise, the package fails to build, like this:

------
ice-9/eval.scm:142:16: In procedure compile-top-call:
error: cc-for-target: unbound variable
hint: Did you forget `(use-modules (guix utils))'?
------

We request that you lint your packages and try building them before
submitting your patches. If you don't know how to do that, that's okay!
Just say so in the patch submission, and we will be happy to help.
diff mbox series

Patch

From f77caa31810add7bddc321f3980170e494f648d4 Mon Sep 17 00:00:00 2001
From: WinterHound <winterhound@yandex.com>
Date: Sun, 18 Apr 2021 15:55:23 +0530
Subject: [PATCH] gnu: Add kirc.

---
 gnu/packages/irc.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index 3953c55a20..3316c2a1db 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -376,6 +376,41 @@  for the IRCv3 protocol.")
      "sic is a simple IRC client, even more minimalistic than ii.")
     (license license:expat)))
 
+(define-public kirc
+  (package
+    (name "kirc")
+    (version "0.2.6")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/mcpcpc/kirc/archive/refs/tags/" version
+                                  ".tar.gz"))
+              (sha256
+               (base32 "084p483npvr9kgmrcyrwnplzvlk1v0rl8fx4z7zw8j61ac2ry67d"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f                      ; no tests
+       #:make-flags
+       (list (string-append "CC=" ,(cc-for-target))
+             (string-append "PREFIX=" %output))
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure))))         ; no configure
+    (synopsis "A tiny IRC client written in POSIX C99")
+    (description
+     "A tiny open-source Internet Relay Chat (IRC) client designed with usability and cross-platform compatibility in mind.
+Features
+    No dependencies other than a C99 compiler.
+    Simple Authentication and Security Layer (SASL) procotol support.
+    Client-to-client (CTCP) protocol support.
+    Transport Layer Security (TLS) protocol support (via external utilities).
+    Simple chat history logging.
+    Asynchronous message handling.
+    Multi-channel joining at server connection.
+    Full support for all RFC 2812 commands.
+    Easy customized color scheme definition.")
+    (home-page "http://kirc.io/index.html")
+    (license license:expat)))
+
 (define-public limnoria
   (package
     (name "limnoria")
-- 
2.31.1