[bug#34393] gnu: terminals: Add termbox-truecolor

Message ID 21686c5a9ff5047728ed5277a6bdd5a0@hypermove.net
State Accepted
Headers show
Series [bug#34393] gnu: terminals: Add termbox-truecolor | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Amirouche Boubekki Feb. 8, 2019, 11:12 p.m. UTC

Comments

Eric Bavier Feb. 9, 2019, 4:38 a.m. UTC | #1
> +(define-public termbox-truecolor
> +  (package
> +    (name "termbox-truecolor")
> +    (version "2019.01.06-c3afbfd")

Could you include a revision number here too?  (See "Version Numbers"
in the manual)

> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/amirouche/termbox-truecolor.git")
> +                    (commit "c3afbfd8f31cce70ffb8c4ddd153489d9e363780")))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +                "179py858dhhxkj6la84b224r2fjwavygf4daw4dgl3gvv8i07ryj"))))
> +    (build-system waf-build-system)
> +    (arguments
> +     `(#:tests? #f))
> +    (synopsis "Library for writing text-based user interfaces (with true-color support)")

Maybe: "Text-based user interface library"

The true-color support can be mentioned in the description.

> +    (description "Termbox is a library that provides minimalistic API which

"...provides a minimalistic ..."
             ^

> +allows the programmer to write text-based user interfaces.
> +
> +It is based on a simple abstraction: viewing terminals as a table of

I think the paragraph break isn't necessary here.

> +fixed-size cells and input being a stream of structured messages.  Copy &
> +pasting and wide characters (mostly Chinese, Japanese, Korean (CJK)
> +characters) are not really supported.")
> +    (home-page "https://github.com/amirouche/termbox-truecolor/tree/truecolor")
> +    (license license:expat)))

Otherwise looks good to me,

`~Eric
Ricardo Wurmus Feb. 9, 2019, 8:58 a.m. UTC | #2
Hi Amirouche,

> From c97de00efc8dfe17a2cedda69033eaa710c42a6e Mon Sep 17 00:00:00 2001
> From: Amirouche <amirouche.boubekki@gmail.com>
> Date: Sat, 9 Feb 2019 00:07:48 +0100
> Subject: [PATCH] gnu: Add termbox-truecolor.
>
> * gnu/packages/terminals.scm (termbox-truecolor): New variable.

Thanks for the patch!

[…]
> +(define-public termbox-truecolor
> +  (package
> +    (name "termbox-truecolor")
> +    (version "2019.01.06-c3afbfd")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/amirouche/termbox-truecolor.git")
> +                    (commit "c3afbfd8f31cce70ffb8c4ddd153489d9e363780")))

It’s better to let-bind the commit and then use (git-version "1.1.0"
commit), because the last release was 1.1.0.

“2019.01.06” is not a version string and it would always be considered a
more recent version than other releases because 2019 is larger than most
major release numbers.
> +    (arguments
> +     `(#:tests? #f))

Could you tell us why the tests are disabled?  If there are no tests
please add a comment “; there are no tests”.

> +    (synopsis "Library for writing text-based user interfaces (with true-color support)")

I think “guix lint” said something about this synopsis being too long.
Could you shorten it a bit?

> +    (home-page
> "https://github.com/amirouche/termbox-truecolor/tree/truecolor")

I think the “tree/truecolor” bit can be removed.
Amirouche May 1, 2019, 1:14 a.m. UTC | #3
I just noticed your comments. I will work on them tomorrow.

There is also the problem that upstream doesn't provide pkg-config file 
: /
Simon Tournier April 12, 2022, 10:08 a.m. UTC | #4
Hi,

Thanks for the submission.


What is the status of this old patch submission [1]?

1: <http://issues.guix.gnu.org/issue/34393>


Since the last interaction is from 2 years, 49 weeks, 3 days ago, I
propose to rebase or close.


Cheers,
simon
Simon Tournier May 19, 2022, 9:18 p.m. UTC | #5
Hi,

On Tue, 12 Apr 2022 at 12:08, zimoun <zimon.toutoune@gmail.com> wrote:

> What is the status of this old patch submission [1]?
>
> 1: <http://issues.guix.gnu.org/issue/34393>
>
>
> Since the last interaction is from 2 years, 49 weeks, 3 days ago, I
> propose to rebase or close.

Since no one is willing to rebase, I am closing.  Feel free to reopen.


Cheers,
simon

Patch

From c97de00efc8dfe17a2cedda69033eaa710c42a6e Mon Sep 17 00:00:00 2001
From: Amirouche <amirouche.boubekki@gmail.com>
Date: Sat, 9 Feb 2019 00:07:48 +0100
Subject: [PATCH] gnu: Add termbox-truecolor.

* gnu/packages/terminals.scm (termbox-truecolor): New variable.
---
 gnu/packages/terminals.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 7f52c6efd..0ff0eda35 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -13,6 +13,7 @@ 
 ;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2018 Gabriel Hondet <gabrielhondet@gmail.com>
 ;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2019 Amirouche Boubekki <amirouche@hypermove.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -36,6 +37,7 @@ 
   #:use-module (guix build-system glib-or-gtk)
   #:use-module (guix build-system go)
   #:use-module (guix build-system python)
+  #:use-module (guix build-system waf)
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module (guix packages)
@@ -1015,3 +1017,30 @@  arbitrary programs of your choice.  This is useful for browsing the history
 comfortably in a pager or editor.
 @end itemize")
     (license license:gpl3+)))
+
+(define-public termbox-truecolor
+  (package
+    (name "termbox-truecolor")
+    (version "2019.01.06-c3afbfd")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/amirouche/termbox-truecolor.git")
+                    (commit "c3afbfd8f31cce70ffb8c4ddd153489d9e363780")))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "179py858dhhxkj6la84b224r2fjwavygf4daw4dgl3gvv8i07ryj"))))
+    (build-system waf-build-system)
+    (arguments
+     `(#:tests? #f))
+    (synopsis "Library for writing text-based user interfaces (with true-color support)")
+    (description "Termbox is a library that provides minimalistic API which
+allows the programmer to write text-based user interfaces.
+
+It is based on a simple abstraction: viewing terminals as a table of
+fixed-size cells and input being a stream of structured messages.  Copy &
+pasting and wide characters (mostly Chinese, Japanese, Korean (CJK)
+characters) are not really supported.")
+    (home-page "https://github.com/amirouche/termbox-truecolor/tree/truecolor")
+    (license license:expat)))
-- 
2.19.1