diff mbox series

[bug#74306,gnome-team,33/44] gnu: libvisual: Update to 0.4.2.

Message ID 2139fe32f58ade8b49ad92f950a4e46fcda226af.1731303037.git.maxim.cournoyer@gmail.com
State New
Headers show
Series gstreamer, GTK, fontmanager updates | expand

Commit Message

Maxim Cournoyer Nov. 11, 2024, 6:17 a.m. UTC
* gnu/packages/gstreamer.scm (libvisual): Update to 0.4.2.
[arguments] <phases>: Use gexps.  Delete trailing #t.
[native-inputs]: Add autoconf, autoconf-archive and automake.
[inputs]: Replace sdl with sdl12-compat.

Change-Id: I6365c767c957102dd4b829cce774e847614d2a72
---
 gnu/packages/gstreamer.scm | 27 ++++++++++++++++-----------
 1 file changed, 16 insertions(+), 11 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 374f206cda..06e3ccb663 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -225,7 +225,7 @@  (define-public ccextractor
 (define-public libvisual
   (package
     (name "libvisual")
-    (version "0.4.0")
+    (version "0.4.2")
     (source
      (origin
        (method git-fetch)
@@ -235,20 +235,25 @@  (define-public libvisual
          (commit (string-append name "-" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "02xwakwkqjsznc03pjlb6hcv1li1gw3r8xvyswqsm4msix5xq18a"))))
+        (base32 "12xf0qzn9w090kakrj59makjbjg9vhga5mgchmx6c1ypw10fjfbc"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         ;; The package is in a sub-dir of this repo.
-         (add-after 'unpack 'chdir
-           (lambda _
-             (chdir "libvisual")
-             #t)))))
+     (list #:phases
+           #~(modify-phases %standard-phases
+               ;; The package is in a sub-dir of this repo.
+               (add-after 'unpack 'chdir
+                 (lambda _
+                   (chdir "libvisual"))))))
     (native-inputs
-     (list gettext-minimal intltool libtool pkg-config))
+     (list autoconf
+           autoconf-archive
+           automake
+           gettext-minimal
+           intltool
+           libtool
+           pkg-config))
     (inputs
-     (list sdl))
+     (list sdl12-compat))
     (native-search-paths
      (list
       (search-path-specification