diff mbox series

[bug#38914] gnu: Add rygel.

Message ID 21391b8e496db214eeea2318c37dfb6e3ef2e4f5.camel@disroot.org
State Accepted
Headers show
Series [bug#38914] gnu: Add rygel. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Raghav Gururajan Jan. 4, 2020, 5:14 a.m. UTC
Hello Guix!

Please find the attached patch to add rygel.

NOTE: This patch depends on #38894, #38896, #38898 and #38901.

Regards,
RG.

Comments

Raghav Gururajan Jan. 13, 2020, 1:38 a.m. UTC | #1
v3
Danny Milosavljevic Jan. 13, 2020, 8:14 a.m. UTC | #2
None of the CC-BY-SA 3.0 licenses are compatible with LGPL.

rygel contains:

The Rygel logo is (c) Chris Kühl <blixtra@gmail.com> and distributed under
CC-BY-SA 3.0

Could you ask upstream what they are thinking?
Raghav Gururajan Jan. 14, 2020, 9:58 p.m. UTC | #3
Hello Danny!

> rygel contains:
> 
> The Rygel logo is (c) Chris Kühl <blixtra@gmail.com> and distributed under
> CC-BY-SA 3.0

Rygel is dual-licensed. Please find the revised patch (v4) attached with this email.

Regards,
RG.
Ludovic Courtès Jan. 15, 2020, 9:34 p.m. UTC | #4
Hi,

"Raghav Gururajan" <raghavgururajan@disroot.org> skribis:

> From 6ebc5f92b58104f9fb39a3208a8157f760bb1007 Mon Sep 17 00:00:00 2001
> From: Raghav Gururajan <raghavgururajan@disroot.org>
> Date: Tue, 14 Jan 2020 16:53:34 -0500
> Subject: [PATCH] gnu: Add rygel.
>
> * gnu/packages/gnome.scm (rygel): New variable.

I tweaked the synopsis and description and committed.

Thanks,
Ludo’.
diff mbox series

Patch

From 7c9bb69e7528bcaaa657fb07bf718a381664f937 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Sat, 4 Jan 2020 00:09:02 -0500
Subject: [PATCH] gnu: Add rygel.

* gnu/packages/gnome.scm (rygel): New variable.
---
 gnu/packages/gnome.scm | 41 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b665d02f33..e5f5a94d49 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9524,6 +9524,47 @@  versions of Adwaita, Adwaita-dark and HighContrast themes.  It also provides
 index files needed for Adwaita to be used outside of GNOME.")
     (license license:lgpl2.1+)))
 
+(define-public rygel
+  (package
+   (name "rygel")
+   (version "0.38.3")
+   (source (origin
+            (method url-fetch)
+            (uri (string-append "mirror://gnome/sources/" name "/"
+                                (version-major+minor version) "/"
+                                name "-" version ".tar.xz"))
+            (sha256
+             (base32
+              "003xficqb08r1dgid20i7cn889lbfwrglpx78rjd5nkvgxbimhh8"))))
+   (build-system gnu-build-system)
+   (native-inputs
+    `(("gettext" ,gettext-minimal)
+      ("pkg-config" ,pkg-config)))
+   (inputs
+    `(("gdk-pixbuf" ,gdk-pixbuf)
+      ("gobject-introspection" ,gobject-introspection)
+      ("gssdp" ,gssdp)
+      ("gstreamer" ,gstreamer)
+      ("gst-plugins-base" ,gst-plugins-base)
+      ("gtk+" ,gtk+)
+      ("gtk-doc" ,gtk-doc)
+      ("gupnp" ,gupnp)
+      ("gupnp-av" ,gupnp-av)
+      ("gupnp-dlna" ,gupnp-dlna)
+      ("libgee" ,libgee)
+      ("libmediaart" ,libmediaart)
+      ("libsoup" ,libsoup)
+      ("libunistring" ,libunistring)
+      ("libxslt" ,libxslt)
+      ("tracker" ,tracker)
+      ("vala" ,vala)))
+   (synopsis "UPnP AV MediaServer and MediaRenderer for GNOME desktop")
+   (description "Rygel is a home media solution that allows you to easily
+share audio, video and pictures, and control of media player on your
+home network.")
+   (home-page "https://wiki.gnome.org/Projects/Rygel")
+   (license license:gpl2+)))
+
 (define-public polari
   (package
     (name "polari")
-- 
2.24.1