From 7c9bb69e7528bcaaa657fb07bf718a381664f937 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Sat, 4 Jan 2020 00:09:02 -0500
Subject: [PATCH] gnu: Add rygel.
* gnu/packages/gnome.scm (rygel): New variable.
---
gnu/packages/gnome.scm | 41 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)
@@ -9524,6 +9524,47 @@ versions of Adwaita, Adwaita-dark and HighContrast themes. It also provides
index files needed for Adwaita to be used outside of GNOME.")
(license license:lgpl2.1+)))
+(define-public rygel
+ (package
+ (name "rygel")
+ (version "0.38.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "003xficqb08r1dgid20i7cn889lbfwrglpx78rjd5nkvgxbimhh8"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gdk-pixbuf" ,gdk-pixbuf)
+ ("gobject-introspection" ,gobject-introspection)
+ ("gssdp" ,gssdp)
+ ("gstreamer" ,gstreamer)
+ ("gst-plugins-base" ,gst-plugins-base)
+ ("gtk+" ,gtk+)
+ ("gtk-doc" ,gtk-doc)
+ ("gupnp" ,gupnp)
+ ("gupnp-av" ,gupnp-av)
+ ("gupnp-dlna" ,gupnp-dlna)
+ ("libgee" ,libgee)
+ ("libmediaart" ,libmediaart)
+ ("libsoup" ,libsoup)
+ ("libunistring" ,libunistring)
+ ("libxslt" ,libxslt)
+ ("tracker" ,tracker)
+ ("vala" ,vala)))
+ (synopsis "UPnP AV MediaServer and MediaRenderer for GNOME desktop")
+ (description "Rygel is a home media solution that allows you to easily
+share audio, video and pictures, and control of media player on your
+home network.")
+ (home-page "https://wiki.gnome.org/Projects/Rygel")
+ (license license:gpl2+)))
+
(define-public polari
(package
(name "polari")
--
2.24.1