diff mbox series

[bug#68290] gnu: obs: Fix VLC plugin.

Message ID 2093dda71d8fbbae0c4bd4bb05fdbfbc6167076a.1704554939.git.go.wigust@gmail.com
State New
Headers show
Series [bug#68290] gnu: obs: Fix VLC plugin. | expand

Commit Message

Oleg Pykhalov Jan. 6, 2024, 3:28 p.m. UTC
* gnu/packages/video.scm (obs)[arguments]<#:phases>: Wrap LD_LIBRARY_PATH.

Change-Id: If22b5294284ea500da0e6d9ee4d4bbcc765c6771
---
 gnu/packages/video.scm | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)


base-commit: 93ac4c20bf4b46b2bb9d0d2b9bec0b728b34de87

Comments

Mathieu Othacehe Jan. 7, 2024, 6:18 p.m. UTC | #1
Hey,

> * gnu/packages/video.scm (obs)[arguments]<#:phases>: Wrap LD_LIBRARY_PATH.

That looks OK!

Thanks,

Mathieu
Oleg Pykhalov Jan. 8, 2024, 11:03 a.m. UTC | #2
Hi Mathieu,

Thank you for the review.

Mathieu Othacehe <othacehe@gnu.org> writes:

>> * gnu/packages/video.scm (obs)[arguments]<#:phases>: Wrap LD_LIBRARY_PATH.
>
> That looks OK!

Pushed to master as 9018c6af4907c4532a95017df9f45d9439c30064.

Oleg.
diff mbox series

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 6da4897a57..5a49f7e03b 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3631,7 +3631,10 @@  (define-public obs
              (lambda* _
                (let ((plugin-path (getenv "QT_PLUGIN_PATH")))
                  (wrap-program (string-append #$output "/bin/obs")
-                   `("QT_PLUGIN_PATH" ":" prefix (,plugin-path)))))))))
+                   `("QT_PLUGIN_PATH" ":" prefix (,plugin-path))
+                   `("LD_LIBRARY_PATH" ":" prefix
+                     (,(string-append #$(this-package-input "vlc")
+                                      "/lib"))))))))))
     (native-search-paths
      (list (search-path-specification
             (variable "OBS_PLUGINS_DIRECTORY")