diff mbox series

[bug#74223,01/11] gnu: Add udis86.

Message ID 207cca13b8755ca8c5d8d0c91b36e8736d5b1d1b.1730877074.git.hako@ultrarare.space
State New
Headers show
Series gnu: Add hyprland. | expand

Commit Message

Hilton Chain Nov. 6, 2024, 7:36 a.m. UTC
* gnu/packages/engineering.scm (udis86): New variable.

Change-Id: I95d6e1dc6dbd07812377633a3290eea9b8102456
---
 gnu/packages/engineering.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 6f449f0c39..0b3431e69c 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -4248,6 +4248,34 @@  (define-public cura-binary-data
 compiled translations.  Prebuilt Firmware files are removed.")
     (license license:agpl3)))
 
+(define-public udis86
+  (let ((commit "5336633af70f3917760a6d441ff02d93477b0c86")
+        (revision "0"))
+    (package
+      (name "udis86")
+      (version (git-version "1.7.2" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/canihavesomecoffee/udis86")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0y5z1169wff578jylpafsww4px4y6gickhcs885a9c660d8xs9qy"))))
+      (build-system gnu-build-system)
+      (native-inputs (list autoconf automake libtool python-minimal-wrapper))
+      ;; Fork of https://github.com/vmt/udis86
+      (home-page "https://github.com/canihavesomecoffee/udis86")
+      (synopsis "Disassembler library for x86 and x86-64")
+      (description
+       "Udis86 is a disassembler for the x86 and x86-64 class of instruction
+set architectures.  It consists of a C library called @code{libudis86} which
+provides a clean and simple interface to decode and inspect a stream of raw
+binary data as disassembled instructions in a structured manner, and a command
+line tool called @command{udcli} that incorporates the library.")
+      (license license:bsd-2))))
+
 (define-public uranium
   (package
     (name "uranium")