diff mbox series

[bug#37451] Update libvterm to version 0.1.1

Message ID 20647564.kr67RFdfiE@aleksandar-ixtreme-m5740
State Accepted
Headers show
Series [bug#37451] Update libvterm to version 0.1.1 | expand

Commit Message

HiPhish Sept. 18, 2019, 7:40 p.m. UTC
This patch bumps the version number of libvterm. The tarball for release 0.1 
has a bug which breaks the terminal emulator inside Neovim, so this new 
release fixes Neovim as well in the process.

Comments

Ricardo Wurmus Sept. 18, 2019, 9 p.m. UTC | #1
Hi HiPhish,

> This patch bumps the version number of libvterm. The tarball for release 0.1
> has a bug which breaks the terminal emulator inside Neovim, so this new
> release fixes Neovim as well in the process.

thank you for this diff!

I’d like to attribute this patch to you, but you’ve sent a diff (not the
output of “git format-patch -1” after a commit) which doesn’t contain
authorship information.  I would write a commit summary according to our
conventions, but I’d need to know with what name and email address you
would like to appear as the author.

--
Ricardo
Ricardo Wurmus Sept. 18, 2019, 9:42 p.m. UTC | #2
Ricardo Wurmus <rekado@elephly.net> writes:

> Hi HiPhish,
>
>> This patch bumps the version number of libvterm. The tarball for release 0.1
>> has a bug which breaks the terminal emulator inside Neovim, so this new
>> release fixes Neovim as well in the process.
>
> thank you for this diff!
>
> I’d like to attribute this patch to you, but you’ve sent a diff (not the
> output of “git format-patch -1” after a commit) which doesn’t contain
> authorship information.  I would write a commit summary according to our
> conventions, but I’d need to know with what name and email address you
> would like to appear as the author.

Thanks for sending me the output of “git format-patch” off-list.  It
wasn’t *quite* the format I expected, so I made a few minor changes to
the commit message and pushed it to the master branch (see commit
b48d77fcf6).

Oh, before that I re-enabled the tests, because they work now.  Yay!

Thanks again!

--
Ricardo
diff mbox series

Patch

diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 98ed77289a..9cf3db8b7f 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -460,7 +460,7 @@  should be thread-safe.")
 (define-public libvterm
   (package
     (name "libvterm")
-    (version "0.1")
+    (version "0.1.1")
     (source
      (origin
        (method url-fetch)
@@ -468,7 +468,7 @@  should be thread-safe.")
                            "libvterm-" version ".tar.gz"))
        (sha256
         (base32
-         "1pcxjhvdwhr2f3lyzf2rv1vp3l62bgkjm1ybhj82qf8yly7ca6g4"))))
+         "1n5maylann2anfifjy576vzyar9q5m1kzpyiz2hca2pacxy8xf4v"))))
     (build-system gnu-build-system)
     (arguments
      `(#:make-flags