[bug#78599,5/7] gnu: emacs-prodigy: Skip tests.
Commit Message
* gnu/packages/emacs-xyz.scm (emacs-prodigy): Skip tests.
[arguments]<test-command>: Set it.
<pĥases>: Add phases 'inject-makel to setup tests.
<tests?>: Skip them, because of a missing input.
[native-inputs]: Add emacs-ecukes, emacs-shut-up, makel.
---
gnu/packages/emacs-xyz.scm | 11 ++++++++++-
1 file changed, 10 insertions(+), 1 deletion(-)
@@ -35583,10 +35583,19 @@ (define-public emacs-prodigy
(base32
"04xspdj67nas1ivv0ldlmmkr6v7zd7y3k346pnfgvq8wzqi6x4vz"))))
(build-system emacs-build-system)
+ (arguments
+ (list #:tests? #f ; XXX: Missing coffescript requirement.
+ #:test-command #~(list "make" "test-ert")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'inject-makel
+ (lambda* (#:key inputs #:allow-other-keys)
+ (symlink (search-input-file inputs "include/makel.mk")
+ "makel.mk"))))))
(propagated-inputs
(list emacs-dash emacs-f emacs-s))
(native-inputs
- (list emacs-el-mock emacs-ert-async))
+ (list emacs-ecukes emacs-el-mock emacs-ert-async emacs-shut-up makel))
(home-page "https://github.com/rejeep/prodigy.el")
(synopsis "Manage external services from within Emacs")
(description "This package provides a GUI for defining and monitoring services.")