[bug#78599,4/7] gnu: emacs-ecukes: Move to (gnu packages emacs-build).
Commit Message
* gnu/packages/emacs-xyz.scm (emacs-ecukes): Move from here…
* gnu/packages/emacs-build.scm (emacs-ecukes): …to here.
---
gnu/packages/emacs-build.scm | 37 ++++++++++++++++++++++++++++++++++++
gnu/packages/emacs-xyz.scm | 37 ------------------------------------
2 files changed, 37 insertions(+), 37 deletions(-)
@@ -173,6 +173,43 @@ (define-public emacs-dash
(description "This package provides a modern list API library for Emacs.")
(license license:gpl3+)))
+(define-public emacs-ecukes
+ (package
+ (name "emacs-ecukes")
+ (version "0.6.18")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ecukes/ecukes")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "182qgddfv8nd89y1l55rs5vm5i61ayc8cxbplb8zx0alnid9xrw1"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:include (cons* "^feature/" "^reporters/" "^templates/" %default-include)
+ ;; 4 unexpected results:
+ ;; FAILED ecukes-run-test/run-step-async-callbacked-no-arg
+ ;; FAILED ecukes-run-test/run-step-async-callbacked-with-arg
+ ;; FAILED ecukes-run-test/run-step-async-callbacked-with-arg-and-args
+ ;; FAILED ecukes-run-test/run-step-async-with-timeout
+ #:tests? #f))
+ (propagated-inputs
+ (list emacs-ansi
+ emacs-commander
+ emacs-dash
+ emacs-espuds
+ emacs-f
+ emacs-s))
+ (home-page "https://github.com/ecukes/ecukes")
+ (synopsis "Cucumber for Emacs")
+ (description
+ "This package provides Ecukes, a Cucumber-inspired integration testing
+tool for Emacs. Ecukes is not a complete clone of Cucumber and is not
+intended to be.")
+ (license license:gpl3+)))
+
(define-public emacs-eldev
(package
(name "emacs-eldev")
@@ -7945,43 +7945,6 @@ (define-public emacs-gdscript-mode
and code formatting.")
(license license:gpl3+)))
-(define-public emacs-ecukes
- (package
- (name "emacs-ecukes")
- (version "0.6.18")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/ecukes/ecukes")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "182qgddfv8nd89y1l55rs5vm5i61ayc8cxbplb8zx0alnid9xrw1"))))
- (build-system emacs-build-system)
- (arguments
- `(#:include (cons* "^feature/" "^reporters/" "^templates/" %default-include)
- ;; 4 unexpected results:
- ;; FAILED ecukes-run-test/run-step-async-callbacked-no-arg
- ;; FAILED ecukes-run-test/run-step-async-callbacked-with-arg
- ;; FAILED ecukes-run-test/run-step-async-callbacked-with-arg-and-args
- ;; FAILED ecukes-run-test/run-step-async-with-timeout
- #:tests? #f))
- (propagated-inputs
- (list emacs-ansi
- emacs-commander
- emacs-dash
- emacs-espuds
- emacs-f
- emacs-s))
- (home-page "https://github.com/ecukes/ecukes")
- (synopsis "Cucumber for Emacs")
- (description
- "This package provides Ecukes, a Cucumber-inspired integration testing
-tool for Emacs. Ecukes is not a complete clone of Cucumber and is not
-intended to be.")
- (license license:gpl3+)))
-
(define-public emacs-ef-themes
(package
(name "emacs-ef-themes")