[bug#78558,1/2] gnu: make-librewolf-source: Delete testing/web-platform.

Message ID 20250523042515.30039-1-ngraves@ngraves.fr
State New
Headers
Series firefox-based browsers: Remove testing/web-platform. |

Commit Message

Nicolas Graves May 23, 2025, 4:25 a.m. UTC
  * gnu/packages/librewolf.scm (make-librewolf-source): Delete
testing/web-platform.  This frees more than 800M of RAM during the
build.  Removing it seems to be enough to allow build on some
machines.
---
 gnu/packages/librewolf.scm | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)
  

Patch

diff --git a/gnu/packages/librewolf.scm b/gnu/packages/librewolf.scm
index 063a89420f..b733709b03 100644
--- a/gnu/packages/librewolf.scm
+++ b/gnu/packages/librewolf.scm
@@ -193,7 +193,11 @@  (define* (make-librewolf-source #:key version firefox-hash librewolf-hash l10n)
        (search-patches
         "librewolf-compare-paths.patch"
         "librewolf-use-system-wide-dir.patch"
-        "librewolf-add-store-to-rdd-allowlist.patch")))))
+        "librewolf-add-store-to-rdd-allowlist.patch"))
+      ;; XXX: 75 Mo (800+ Mo uncompressed) of unused tests.
+      ;; Removing it makes it possible to compile on some systems.
+      (modules '((guix build utils)))
+      (snippet #~(delete-file-recursively "testing/web-platform")))))
 
 ;;; Define the versions of rust needed to build firefox, trying to match
 ;;; upstream.  See table at [0], `Uses' column for the specific version.