[bug#78556] gnu: python-xapian-bindings: Fix build.
Commit Message
* gnu/packages/search.scm (python-xapian-bindings)[arguments]: Improve
style (move to gexps).
[arguments]<make-flags>: Set PYTHON3_SO flag.
---
gnu/packages/search.scm | 17 ++++++++++-------
1 file changed, 10 insertions(+), 7 deletions(-)
@@ -160,13 +160,16 @@ (define-public python-xapian-bindings
"0gc8l9cn8jdma0p73jl14z17yizp6dax5zsycvgprajii6j8bhwi"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags '("--with-python3")
- #:make-flags
- (list (string-append "pkgpylibdir="
- (assoc-ref %outputs "out")
- "/lib/python" ,(version-major+minor
- (package-version python))
- "/site-packages/xapian"))))
+ (list #:configure-flags #~(list "--with-python3")
+ #:make-flags
+ #~(list (string-append "pkgpylibdir="
+ #$output
+ "/lib/python" #$(version-major+minor
+ (package-version python))
+ "/site-packages/xapian")
+ ;; XXX: Otherwise set to "None", which produces _xapianNone
+ ;; and ends up unable to find it.
+ "PYTHON3_SO=.so")))
(native-inputs
(list python-sphinx)) ;for documentation
(inputs