[bug#78539,07/13] gnu: Add rust-envconfig-derive@0.11.0
Commit Message
Change-Id: I5d19746cdf4bc21311366e4f6a6bb79c92f70beb
---
gnu/packages/crates-io.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)
@@ -12607,6 +12607,30 @@ (define-public rust-chumsky-0.9
recovery.")
(license license:expat)))
+(define-public rust-envconfig-derive-0.11
+ (package
+ (name "rust-envconfig-derive")
+ (version "0.11.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "envconfig_derive" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1cb9g9zcglf9fw7dc9099x8fwp115yx00lwxbv8pmdi0f861yafl"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-syn" ,rust-syn-2)
+ ("rust-quote" ,rust-quote-1)
+ ("rust-proc-macro2" ,rust-proc-macro2-1))))
+ (home-page "https://github.com/greyblake/envconfig-rs")
+ (synopsis "Build a config structure from environment variables in Rust
+without boilerplate")
+ (description
+ "Initialize config structure from environment variables in Rust without
+boilerplate.")
+ (license license:expat)))
+
(define-public rust-envmnt-0.10
(package
(name "rust-envmnt")