[bug#78539,06/13] gnu: Add rust-assert-hex@0.4.1
Commit Message
Change-Id: I86919e51b8b8740c058cb452e5c16139273b96e2
---
gnu/packages/crates-io.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)
@@ -4346,6 +4346,27 @@ (define-public rust-assert-fs-1
"This crate provides file system fixtures and assertions for testing.")
(license (list license:expat license:asl2.0))))
+(define-public rust-assert-hex-0.4
+ (package
+ (name "rust-assert-hex")
+ (version "0.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "assert_hex" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "19xwlhz2swak1gw6rv38wai7d1xn9l3mspnv1fl8rz7h60a0y0gp"))))
+ (build-system cargo-build-system)
+ (home-page "https://github.com/wcampbell0x2a/assert_hex")
+ (synopsis "Rust library to display assert panics in hexadecimal format")
+ (description
+ "Writing and testing protocol level libraries requires many tests to be
+written with respect to byte level protocol sections in hex. This library
+simplifies the process of viewing the differences between these types when
+tests fail by displaying by using the {:#x?} representation.")
+ (license license:expat)))
+
(define-public rust-assert-impl-0.1
(package
(name "rust-assert-impl")