[bug#78494,python-team] gnu: awscli-2: Skip failing tests.
Commit Message
Skips two failing tests with the awscli-2 package, which have been
failing the build recently.
The first one is related to the version of prompt-toolkit that's being
used as an input. Upstream doesn't support some of the later versions,
however this doesn't seem to cause any visible problems right now apart
from the test failing, at least on aarch64.
The other issue is due to `os.environ["PATH"]` throwing a KeyError once
in a while, seems like this test is being affected by some other test
since running it in isolation works for me. See
<https://ci.guix.gnu.org/build/10641072/log> for an example.
* gnu/packages/python-web.scm (awscli-2)[arguments]<#:test-flags>: Skip
failing prompt-toolkit tests, likewise for emrutils.
---
gnu/packages/python-web.scm | 13 ++++++++++---
1 file changed, 10 insertions(+), 3 deletions(-)
@@ -5207,12 +5207,19 @@ (define-public awscli-2
(arguments
(list
#:test-flags
- ;; The resource leak tests use ps to check for memory consumption.
- '(list "--ignore=functional/botocore/leak/test_resource_leaks.py"
+ '(list ;; This version of prompt-toolkit has issues with awscli-2, see
+ ;; <https://github.com/aws/aws-cli/issues/9453#issuecomment-2822186530>.
+ "--ignore=functional/autoprompt/test_prompttoolkit.py"
+ ;; The resource leak tests use ps to check for memory consumption.
+ "--ignore=functional/botocore/leak/test_resource_leaks.py"
;; These tests complain about unavailable TLS certs.
"--ignore=functional/ec2instanceconnect/test_opentunnel.py"
;; These seem to require Internet access.
- "--ignore=unit/botocore/test_awsrequest.py")
+ "--ignore=unit/botocore/test_awsrequest.py"
+ ;; Flaky, something to do with PATH disappearing from os.environ?
+ ;; Passes when run on its own, so maybe something else is
+ ;; modifying this during the test run.
+ "--ignore=unit/customizations/emr/test_emr_utils.py")
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'ignore-deprecations