[bug#78395] gnu: Add log4cxx
Commit Message
* gnu/packages/logging.scm (log4cxx): New variable.
Change-Id: I486d2968a434c0b26fac49164797b3ff193b1934
---
gnu/packages/logging.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)
base-commit: bf11e3327b64dbaaab9b6a688f2f1f9871c9d63d
@@ -35,6 +35,7 @@ (define-module (gnu packages logging)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
#:use-module (gnu packages)
+ #:use-module (gnu packages apr)
#:use-module (gnu packages autotools)
#:use-module (gnu packages bison)
#:use-module (gnu packages c)
@@ -94,6 +95,27 @@ (define-public log4cpp
(home-page "https://log4cpp.sourceforge.net/")
(license license:lgpl2.1+)))
+(define-public log4cxx
+ (package
+ (name "log4cxx")
+ (version "1.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://apache/logging/log4cxx/" version
+ "/apache-log4cxx-" version ".tar.gz"))
+ (sha256
+ (base32 "15kgxmqpbg8brf7zd8mmzr7rvm9zrigz3ak34xb18v2ld8siyb9x"))))
+ (build-system cmake-build-system)
+ (native-inputs (list apr apr-util pkg-config zip))
+ (home-page "https://logging.apache.org/log4cxx/")
+ (synopsis "C++ logging library patterned after Apache log4j")
+ (description
+ "A C++ logging framework patterned after Apache
+log4j which uses Apache Portable Runtime for most platform-specific code
+and should be usable on any platform supported by APR")
+ (license license:asl2.0)))
+
(define-public glog
(package
(name "glog")