[bug#78315,11/53] gnu: emacs-flymake-shellcheck: Use search-input-file.

Message ID 20250508125104.26530-11-ngraves@ngraves.fr
State New
Headers
Series More fixes, and a lot of style improvements. |

Commit Message

Nicolas Graves May 8, 2025, 12:50 p.m. UTC
  * gnu/packages/emacs-xyz.scm (emacs-flymake-shellcheck):
  [arguments]<phases>: Improve phase 'substitute-shellcheck-path.
---
 gnu/packages/emacs-xyz.scm | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)
  

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2aa2b8b801..368710d2cc 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3501,8 +3501,7 @@  (define-public emacs-flymake-shellcheck
                (emacs-substitute-sexps "flymake-shellcheck.el"
                  ("defcustom flymake-shellcheck-path"
                   `(or (executable-find "shellcheck")
-                       ,(string-append (assoc-ref inputs "shellcheck")
-                                       "/bin/shellcheck")))))))))
+                       ,(search-input-file inputs "bin/shellcheck")))))))))
       (inputs
        (list shellcheck))
       (home-page "https://github.com/federicotdn/flymake-shellcheck")