[bug#73152,v2,6/6] gnu: nss-certs: Update to 3.101.3.
Commit Message
* gnu/packages/certs.scm (nss-certs): Update to 3.101.3.
Change-Id: Ibe9aa969046d375eea308594ac1a3c1cf23f75c2
---
gnu/packages/certs.scm | 15 +++++++++------
1 file changed, 9 insertions(+), 6 deletions(-)
@@ -133,18 +133,21 @@ (define-public nss-certs
;; FIXME We used to refer to the nss package here, but that eventually caused
;; module cycles. The below is a quick copy-paste job that must be kept in
;; sync manually. Surely there's a better way…?
- (version "3.99")
+ (version "3.101.3")
(source (origin
(method url-fetch)
- (uri (let ((version-with-underscores
- (string-join (string-split version #\.) "_")))
+ (uri (let* ((versions (string-split version #\.))
+ (directory-version (string-join versions "_"))
+ ;; 3.101.3 release has a typo in the filename.
+ (filename-version
+ (if (string=? "3.101.3" version) "3.101_3" version)))
(string-append
"https://ftp.mozilla.org/pub/mozilla.org/security/nss/"
- "releases/NSS_" version-with-underscores "_RTM/src/"
- "nss-" version ".tar.gz")))
+ "releases/NSS_" directory-version "_RTM/src/"
+ "nss-" filename-version ".tar.gz")))
(sha256
(base32
- "1g89ig40gfi1sp02gybvl2z818lawcnrqjzsws36cdva834c5maw"))
+ "1gkpbyh90aw9yhjnyj1bsp79s2bxab886d9ihkaw1i2kzqfvf3dg"))
;; Create nss.pc and nss-config.
(patches (search-patches "nss-3.56-pkgconfig.patch"
"nss-getcwd-nonnull.patch"