[bug#78219] gnu: Add python-vcstool

Message ID 20250502192708.665937-1-elwin@northwestern.edu
State New
Headers
Series [bug#78219] gnu: Add python-vcstool |

Commit Message

Matthew Elwin May 2, 2025, 7:27 p.m. UTC
  * gnu/packages/python-xyz.scm (python-vcstool): New Variable

Change-Id: I5e3485cd1f53a379121a09938d5e45cd641a0317
---
 gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)


base-commit: 0b83a27b67ae92e988795322ae988518ec3e6972
  

Comments

Sharlatan Hellseher May 3, 2025, 2:26 p.m. UTC | #1
Hi,

Thanks for the patch.

You might need to wrap git, breezy and subversion; check Nix package for
ideas and similar wrapping logic in Guix package base
<https://github.com/NixOS/nixpkgs/blob/nixos-24.11/pkgs/by-name/vc/vcstool/package.nix#L40>

--
Oleg
  

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f3d23215ed..d04d139074 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -163,6 +163,7 @@ 
 ;;; Copyright © 2025 Dariqq <dariqq@posteo.net>
 ;;; Copyright © 2025 Nguyễn Gia Phong <mcsinyx@disroot.org>
 ;;; Copyright © 2025, Cayetano Santos <csantosb@inventati.org>
+;;; Copyright © 2025, Matthew Elwin <elwin@northwestern.edu>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -5081,6 +5082,26 @@  (define-public python-case
 some helpful Python 2 compatibility convenience methods.")
     (license license:bsd-3)))
 
+(define-public python-vcstool
+  (package
+    (name "python-vcstool")
+    (version "0.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "vcstool" version))
+       (sha256
+        (base32 "0b7f68q25x9nxqa3xcg32js3qgp4jg99anwy2c7nd1jkw5iskcq4"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-pyyaml python-setuptools))
+    (native-inputs (list python-setuptools python-wheel))
+    (home-page "https://github.com/dirk-thomas/vcstool")
+    (synopsis
+     "Command line tool to invoke version control commands on multiple repositories")
+    (description
+     "Enables manipulating multiple version control repositories with one command.")
+    (license license:asl2.0)))
+
 (define-public python-verboselogs
   (package
     (name "python-verboselogs")