[bug#78190,go-team] gnu: lyrebird: Add version info.

Message ID 20250501145403.7722-1-nandre@riseup.net
State New
Headers
Series [bug#78190,go-team] gnu: lyrebird: Add version info. |

Commit Message

André Batista May 1, 2025, 2:54 p.m. UTC
  See the project's Makefile.  Without this flag, version info defaults
to 'devel'.

* gnu/packages/golang-web.scm (lyrebird)[arguments]<#:build-flags>: Add
ldflag required for building with version information; append default
ldflags in case they are shadowed.

Change-Id: Iaa94c205244b3028b7e935b5ff83cf16b67f1b95
---
 gnu/packages/golang-web.scm | 3 +++
 1 file changed, 3 insertions(+)


base-commit: f58462958d29e0fa1e391790385a929f26702b7b
  

Patch

diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 892bd25fd67..20ba7e663b1 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -10756,6 +10756,9 @@  (define-public lyrebird
     (arguments
      (list
       #:go go-1.22
+      #:build-flags #~(list (string-append "-ldflags="
+                                           "-X main.lyrebirdVersion="
+                                           #$version " -s -w"))
       #:install-source? #f
       #:unpack-path "gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/lyrebird"
       #:import-path "gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/lyrebird/cmd/lyrebird"))