[bug#78154,1/5] gnu: Add catch2-3.8

Message ID 20250430001507.912670-1-nomike@nomike.com
State New
Headers
Series Update priusa-sicer to version 2.9.2 |

Commit Message

nomike April 30, 2025, 12:15 a.m. UTC
  * gnu/packages/check.scm (catch2-3.8): New variable

Change-Id: I8286d4b71fc09bbcdc483c920710dc881fc82aba
---
 gnu/packages/check.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
  

Patch

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 3fe7214645..8e498ed3e5 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -54,6 +54,7 @@ 
 ;;; Copyright © 2024 Navid Afkhami <navid.afkhami@mdc-berlin.de>
 ;;; Copyright © 2024, 2025 gemmaro <gemmaro.dev@gmail.com>
 ;;; Copyright © 2024 Ashvith Shetty <ashvithshetty10@gmail.com>
+;;; Copyright © 2025 nomike Postmann <nomike@nomike.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -735,6 +736,33 @@  (define-public catch2-3
 a multi-paradigm automated test framework for C++ and Objective-C.")
     (license license:boost1.0)))
 
+(define-public catch2-3.8
+  (package
+    (name "catch2")
+    (version "3.8.1")
+    (home-page "https://github.com/catchorg/Catch2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/catchorg/Catch2")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0v1k14n02aiw4rv5sxhc5612cjhkdj59cjpm50qfxhapsdv54n3f"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list
+      #:configure-flags
+      #~(list "-DCATCH_DEVELOPMENT_BUILD=ON" "-DCATCH_ENABLE_WERROR=OFF"
+              "-DBUILD_SHARED_LIBS=ON")))
+    (inputs (list python-wrapper))
+    (synopsis "Automated test framework for C++ and Objective-C")
+    (description
+     "Catch2 stands for C++ Automated Test Cases in Headers and is
+a multi-paradigm automated test framework for C++ and Objective-C.")
+    (license license:boost1.0)))
+
 (define-public cmdtest
   (package
     (name "cmdtest")