[bug#78138] gnu: Add python-scspell3k.

Message ID 20250429202642.330699-1-elwin@northwestern.edu
State New
Headers
Series [bug#78138] gnu: Add python-scspell3k. |

Commit Message

Matthew Elwin April 29, 2025, 8:26 p.m. UTC
  * gnu/packages/python-xyz.scm (python-scspell3k): New variable.

Change-Id: Ia7e7d9cceba1391eee9278ab722bcdd4283c1354
---
 gnu/packages/python-check.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)


base-commit: fbf766295710078b5cd2e8810459908d9f777442
  

Patch

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index eb4d62a294..87d86a1705 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -3342,6 +3342,30 @@  (define-public python-robotframework-jsonlibrary
     ;; This is free and unencumbered software released into the public domain.
     (license license:unlicense)))
 
+(define-public python-scspell3k
+  (let ((commit "bb598b26881b034eaade59857d43050fff7b920b")
+        (revision "1"))
+    (package
+      (name "python-scspell3k")
+      (version (git-version "2.3.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/myint/scspell")
+               (commit commit)))
+         (sha256
+          (base32 "1rw1vmklmf974p4pqgd4klcf9z1ygxapgmp4ldm9jf47xg7is9ay"))
+         (file-name (git-file-name name version))))
+      (build-system pyproject-build-system)
+      (native-inputs (list python-setuptools python-wheel))
+      (home-page "https://github.com/myint/scspell")
+      (synopsis "Conservative interactive spell checker for source code")
+      (description
+       "A spell checker for source code that does not try to be particularly smart
+and instead does the simplest thign that can possibly work.")
+      (license license:gpl2))))
+
 (define-public python-slotscheck
   (package
     (name "python-slotscheck")