[bug#78138] gnu: Add python-scspell3k.
Commit Message
* gnu/packages/python-xyz.scm (python-scspell3k): New variable.
Change-Id: If16df188d7d17e892cfa434d8c3e8dbe7135e271
---
.../python-scspell3k-pyproject-license.patch | 16 +++++++++++++
gnu/packages/python-xyz.scm | 24 +++++++++++++++++++
2 files changed, 40 insertions(+)
create mode 100644 gnu/packages/patches/python-scspell3k-pyproject-license.patch
base-commit: fbf766295710078b5cd2e8810459908d9f777442
Comments
Hi,
Thank you for the patch.
Please check some review points
Please, place the package to python-check in alphabetical order as it's
the best fit for it.
home-page: -> https://github.com/myint/scspell
tetsts?: there are tests if you use git fetch
patch: you may use the latest commit containing the same changes, https://github.com/myint/scspell/blob/df550351f255c572c1a74852d233c83bbfbd49fb/pyproject.toml#L11C1-L13C23
--8<---------------cut here---------------start------------->8---
version = "2.3.0"
license = "GPL-2.0-only"
readme = "README.rst"
--8<---------------cut here---------------end--------------->8---
Looking forward for v2!
--
Oleg
Hi,
I've managed to build it on the latest commit with minot adjustments.
Pushed to master as 3cecec63c5762efa037d2b7885366ac20990b97c.
--
Oleg
new file mode 100644
@@ -0,0 +1,16 @@
+diff -urN scspell3k-2.3.0/pyproject.toml scspell3k-2.3.0-patched/pyproject.toml
+--- scspell3k-2.3.0/pyproject.toml 2025-04-06 12:29:17.000000000 -0500
++++ scspell3k-2.3.0-patched/pyproject.toml 2025-04-29 09:10:39.804229321 -0500
+@@ -9,9 +9,11 @@
+ description = "A conservative interactive spell checker for source code."
+
+ version = "2.3.0"
+-license = "GPL-2.0-only"
+ readme = "README.rst"
+
++[project.license]
++text = "GPL-2.0-only"
++
+ classifiers = [
+ 'Development Status :: 4 - Beta',
+ 'Environment :: Console',
@@ -163,6 +163,7 @@
;;; Copyright © 2025 Dariqq <dariqq@posteo.net>
;;; Copyright © 2025 Nguyễn Gia Phong <mcsinyx@disroot.org>
;;; Copyright © 2025, Cayetano Santos <csantosb@inventati.org>
+;;; Copyright © 2025, Matthew Elwin <elwin@northwestern.edu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -816,6 +817,29 @@ (define-public python-pyxdameraulevenshtein
edit distance algorithm for Python in Cython for high performance.")
(license license:bsd-3)))
+(define-public python-scspell3k
+ (package
+ (name "python-scspell3k")
+ (version "2.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "scspell3k" version))
+ (sha256
+ (base32 "012xhmz3an7b2s9kwkdsxlnwiqjj64sy5kxp5kffa3gzjcai7qgv"))
+ (patches (search-patches "python-scspell3k-pyproject-license.patch"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:tests? #f))
+ (native-inputs (list python-setuptools python-wheel))
+ (home-page "https://pypi.org/project/scspell3k/")
+ (synopsis "Conservative interactive spell checker for source code")
+ (description
+ "A spell checker for source code that does not try to be particularly smart
+and instead does the simplest thign that can possibly work.")
+ (license license:gpl2)))
+
(define-public python-shxparser
(package
(name "python-shxparser")