[bug#78115] gnu: Add python-flake8-comprehensions
Commit Message
* gnu/packages/python-check.scm (python-flake8-comprehensions): New variable.
Change-Id: Ibb58ffce8d12a1c6444b89723a7882f88373496f
---
gnu/packages/python-check.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)
base-commit: d47379b8dc6fb79bd9f06598ce567aec80194365
prerequisite-patch-id: cc884137a4ef938c8055c44a5b66329bf65ef1ba
@@ -676,6 +676,30 @@ (define-public python-flake8-builtins
being used as variables or parameters.")
(license license:gpl2)))
+(define-public python-flake8-comprehensions
+ (package
+ (name "python-flake8-comprehensions")
+ (version "3.16.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "flake8_comprehensions" version))
+ (sha256
+ (base32 "1gpsr9lga7l7gcm2nm73gina3nb4n8bjpf0g6nfkzw580ncpigww"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:tests? #f))
+ (propagated-inputs (list python-flake8))
+ (native-inputs (list python-setuptools python-wheel))
+ (home-page "https://pypi.org/project/flake8-comprehensions/")
+ (synopsis
+ "This flake8 plugin helps you write better list/set/dict comprehensions")
+ (description
+ "This package provides a flake8 plugin to help you write better list/set/dict
+comprehensions.")
+ (license license:expat)))
+
(define-public python-flake8-deprecated
(package
(name "python-flake8-deprecated")