[bug#78114] gnu: Add python-flake8-deprecated
Commit Message
* gnu/packages/python-check.scm (python-flake8-deprecated): New variable.
Change-Id: If555230ff854ad26c5466a47b04a212189a113b9
---
gnu/packages/python-check.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)
base-commit: d47379b8dc6fb79bd9f06598ce567aec80194365
@@ -676,6 +676,30 @@ (define-public python-flake8-builtins
being used as variables or parameters.")
(license license:gpl2)))
+(define-public python-flake8-deprecated
+ (package
+ (name "python-flake8-deprecated")
+ (version "2.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "flake8_deprecated" version))
+ (sha256
+ (base32 "18iazzh2l42fcjmkqdwncsl1h2s6sbi26vz4m0gmd80w3l0cm5pf"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ #~(list "run_tests.py")))
+ (propagated-inputs (list python-flake8))
+ (native-inputs (list python-hatchling python-pytest))
+ (home-page "https://github.com/gforcada/flake8-deprecated")
+ (synopsis "Warns about deprecated method calls")
+ (description
+ "This flake8 plugin helps you keep up with method deprecations
+by providing hints about what deprecated methods should be replaced with.")
+ (license license:gpl2)))
+
(define-public python-gcovr
(package
(name "python-gcovr")