[bug#78066,2/2] gnu: fail2ban: Build with Python 3.10.

Message ID 20250425201809.13507-2-rodion@goritskov.com
State New
Headers
Series Fix fail2ban build |

Commit Message

Rodion Goritskov April 25, 2025, 8:18 p.m. UTC
  * gnu/packages/admin.scm (fail2ban): Change Python version used to 3.10 to fix
test problems.

Change-Id: I67d2cf3c465ab1639659402d50357395afb35213
---
 gnu/packages/admin.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
  

Patch

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index d7ae926809..225ae87b06 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -6289,7 +6289,8 @@  (define-public fail2ban
                         "fail2ban-paths-guix-conf.patch"))))
     (build-system python-build-system)
     (arguments
-     '(#:phases (modify-phases %standard-phases
+     `(#:python ,(wrap-python3 python-3.10)
+       #:phases (modify-phases %standard-phases
                   (add-before 'build 'invoke-2to3
                     (lambda _
                       (invoke "./fail2ban-2to3")))