[bug#78027] 2025-04-22 Matthew Elwin <elwin@northwestern.edu>
Commit Message
gnu: python-flake8-builtins
* gnu/packages/python-xyz.scm (python-flake8-builtins): New package.
Change-Id: I1fe2b01f3e95b922ec2a7f48024a2a9ffd598894
---
gnu/packages/python-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)
base-commit: 6cf0f3cbb649b8be21dcc6337ef394902c4bd56c
@@ -619,6 +619,29 @@ (define-public python-distance
implemented in pure Python, and most of them are also implemented in C.")
(license license:gpl2+)))
+(define-public python-flake8-builtins
+ (package
+ (name "python-flake8-builtins")
+ (version "2.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "flake8_builtins" version))
+ (sha256
+ (base32 "19psav7pnqy3m5g4z1zah4ksbnk9bzx1jbbibs631xg44gc3vamx"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:tests? #f))
+ (propagated-inputs (list python-flake8))
+ (native-inputs (list python-hatchling python-pytest))
+ (home-page "https://github.com/gforcada/flake8-builtins")
+ (synopsis
+ "Check for python builtins being used as variables or parameters")
+ (description
+ "Check for python builtins being used as variables or parameters.")
+ (license license:gpl2)))
+
(define-public python-flake8-class-newline
(package
(name "python-flake8-class-newline")