[bug#77895,v2,08/10] gnu: python-commentjson: Switch to python-lark.

Message ID 20250422140051.2273-8-ngraves@ngraves.fr
State New
Headers
Series [bug#77895,v2,01/10] gnu: Add python-lark. |

Commit Message

Nicolas Graves April 22, 2025, 2 p.m. UTC
  * gnu/packages/python-xyz.scm (python-commentjson):
[arguments]{phases}: Refresh phase 'relax-requirements.
[propagated-inputs]: Replace python-lark-parser by python-lark.
---
 gnu/packages/python-xyz.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
  

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 53647516e3..2743a94203 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17582,7 +17582,7 @@  (define-public python-commentjson
            (lambda _
              (substitute* "setup.py"
                (("lark-parser>=0.7.1,<0.8.0")
-                "lark-parser>=0.7.1"))))
+                "lark"))))
          (add-after 'unpack 'delete-unspported-tests
            ;; Some tests rely on the 'test' module of Python itself,
            ;; which is not available with the Python package in Guix;
@@ -17600,7 +17600,7 @@  (define (grep string file-name)
                            (filter (lambda (f) (grep "from test." f))
                                    test-files)))))))))
     (propagated-inputs
-     (list python-lark-parser))
+     (list python-lark))
     (native-inputs
      (list python-six))
     (home-page "https://github.com/vaidik/commentjson")