[bug#77895,v2,02/10] gnu: python-suds: Fix dist-info.

Message ID 20250422140051.2273-2-ngraves@ngraves.fr
State New
Headers
Series [bug#77895,v2,01/10] gnu: Add python-lark. |

Commit Message

Nicolas Graves April 22, 2025, 2 p.m. UTC
  * gnu/packages/python-web.scm (python-suds)
[arguments]{phases}: Add phase 'add-custom-dist-info.
---
 gnu/packages/python-web.scm | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)
  

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 8fe9f58978..d86567fd2e 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -10605,6 +10605,22 @@  (define-public python-suds
        (sha256
         (base32 "1byyg7b2ixpr8hc849a6dd0qn5daxqawz6lb3php8lrmsb1n5cc3"))))
     (build-system pyproject-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               ;; XXX: chirp expects suds instead of suds_community
+               (add-after 'install 'add-custom-dist-info
+                 (lambda _
+                   (for-each
+                    (lambda (dir)
+                      (with-directory-excursion (dirname dir)
+                        (symlink
+                         (basename dir)
+                         (string-append "suds-" #$version ".dist-info"))))
+                    (find-files #$output
+                                (lambda (file stat)
+                                  (string-suffix? ".dist-info" file))
+                                #:directories? #t)))))))
     (native-inputs
      (list python-pytest
            python-setuptools