[bug#77822,v2] gnu: emacs-denote-menu: Update to 1.4.0.
Commit Message
From: Cayetano Santos <csantosb@inventati.org>
* gnu/packages/emacs-xyz.scm (emacs-denote-menu): Update to 1.4.0.
[source]: Switch to git-fetch.
[arguments]<#:tests>: Disable.
Change-Id: Ia016629bb672bfff7fd46fd67569712529e1886d
---
gnu/packages/emacs-xyz.scm | 13 ++++++++-----
1 file changed, 8 insertions(+), 5 deletions(-)
@@ -19789,15 +19789,18 @@ (define-public emacs-denote
(define-public emacs-denote-menu
(package
(name "emacs-denote-menu")
- (version "1.3.0")
+ (version "1.4.0")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://elpa.gnu.org/packages/"
- "denote-menu-" version ".tar"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/namilus/denote-menu")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "0flkb3f1zpp3sbjx6h7qb6fnjgg44s53zkv3q3fj6cl7c0f11n02"))))
+ (base32 "15kaf45ndyg4xvgnpn8qwapkgcswasykcqfpkr0mny35a3jhdgrq"))))
(build-system emacs-build-system)
+ (arguments (list #:tests? #f)) ; no tests
(propagated-inputs (list emacs-denote))
(home-page "https://www.scss.tcd.ie/~sulimanm/posts/denote-menu.html")
(synopsis "View and filter Denote files in a tabulated list")