[bug#77895,4/7] gnu: Remove python-mox3.
Commit Message
This python library is now a leaf package undevelopped for 5 years and
not failing on the latest python version.
* gnu/packages/openstack.scm (python-mox3): Remove variable.
* gnu/packages/patches/python-mox3-python3.6-compat.patch: Remove
patch.
* gnu/local.mk: Deregister patch.
---
gnu/local.mk | 1 -
gnu/packages/openstack.scm | 26 -----------
.../python-mox3-python3.6-compat.patch | 43 -------------------
3 files changed, 70 deletions(-)
delete mode 100644 gnu/packages/patches/python-mox3-python3.6-compat.patch
@@ -2127,7 +2127,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-pyfakefs-remove-bad-test.patch \
%D%/packages/patches/python-libxml2-utf8.patch \
%D%/packages/patches/python-memcached-syntax-warnings.patch \
- %D%/packages/patches/python-mox3-python3.6-compat.patch \
%D%/packages/patches/python-packaging-test-arch.patch \
%D%/packages/patches/python-property-cached-asyncio-3_11.patch \
%D%/packages/patches/python-pyan3-fix-absolute-path-bug.patch \
@@ -181,32 +181,6 @@ (define-public python-hacking
guidelines}.")
(license asl2.0)))
-(define-public python-mox3
- (package
- (name "python-mox3")
- (version "0.24.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "mox3" version))
- (patches (search-patches "python-mox3-python3.6-compat.patch"))
- (sha256
- (base32
- "0w58adwv7q9wzvmq9mlrk2asfk73myq9fpwy7mjkzsz3baa95zf5"))))
- (build-system python-build-system)
- (propagated-inputs
- (list python-fixtures python-pbr))
- (native-inputs
- (list python-openstackdocstheme python-sphinx python-subunit
- python-testrepository python-testtools))
- (home-page "https://www.openstack.org/")
- (synopsis "Mock object framework for Python")
- (description
- "Mox3 is an unofficial port of the @uref{https://code.google.com/p/pymox/,
-Google mox framework} to Python 3. It was meant to be as compatible
-with mox as possible, but small enhancements have been made.")
- (license asl2.0)))
-
(define-public python-openstackdocstheme
(package
(name "python-openstackdocstheme")
deleted file mode 100644
@@ -1,43 +0,0 @@
-Fix regex so that it works with Python 3.6.
-
-See <https://docs.python.org/3/library/re.html#re.LOCALE>.
-
-Copied from upstream bug report:
-https://bugs.launchpad.net/python-mox3/+bug/1665266
-
-From 05064cdb6ea7a16450c6beae2b6f7c6074212a69 Mon Sep 17 00:00:00 2001
-From: Zac Medico <zmedico@gentoo.org>
-Date: Thu, 16 Feb 2017 00:24:10 -0800
-Subject: [PATCH] RegexTest: python3.6 compatibility
-
-These fixes are backward-compatible with older python versions:
-
-* raw strings fix invalid escape sequences
-* flags=8 fixes ValueError: cannot use LOCALE flag with a str pattern
----
- mox3/tests/test_mox.py | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/mox3/tests/test_mox.py b/mox3/tests/test_mox.py
-index 15ac565..3a1af17 100644
---- a/mox3/tests/test_mox.py
-+++ b/mox3/tests/test_mox.py
-@@ -312,12 +312,12 @@ class RegexTest(testtools.TestCase):
- def testReprWithoutFlags(self):
- """repr should return the regular expression pattern."""
- self.assertTrue(
-- repr(mox.Regex(r"a\s+b")) == "<regular expression 'a\s+b'>")
-+ repr(mox.Regex(r"a\s+b")) == r"<regular expression 'a\s+b'>")
-
- def testReprWithFlags(self):
- """repr should return the regular expression pattern and flags."""
-- self.assertTrue(repr(mox.Regex(r"a\s+b", flags=4)) ==
-- "<regular expression 'a\s+b', flags=4>")
-+ self.assertTrue(repr(mox.Regex(r"a\s+b", flags=8)) ==
-+ r"<regular expression 'a\s+b', flags=8>")
-
-
- class IsTest(testtools.TestCase):
-2.10.2
-